On 6/14/23 19:44, Stephen Hemminger wrote:
On Wed, 14 Jun 2023 17:20:59 +0200 Thomas Monjalon <[email protected]> wrote:Two functions helping to check Rx/Tx queues validity were added in DPDK 23.07-rc1. As the release is not closed, it is still time to rename. The name proposed originally rte_eth_dev_is_valid_*xq is consistent with this function: rte_eth_dev_is_valid_port() However, the suffixes "rxq" and "txq" are uncommon in ethdev functions. Also for shortness, many functions are dropping "_dev_" as these functions which manage the queues: rte_eth_*x_queue_info_get() rte_eth_*x_queue_setup() rte_eth_*x_hairpin_queue_setup For completeness, there are some old functions having "_dev_": rte_eth_dev_*x_queue_start() rte_eth_dev_*x_queue_stop() Anyway in all above examples, the subject is after the prefix, and the verb is at the end. That's why I propose renaming into: rte_eth_*x_queue_is_valid() Fixes: 7ea7e0cd3a08 ("ethdev: add functions to check queue validity") Signed-off-by: Thomas Monjalon <[email protected]>Shorter is better. Acked-by: Stephen Hemminger <[email protected]>
Acked-by: Andrew Rybchenko <[email protected]>

