> -----Original Message----- > From: Morten Brørup <m...@smartsharesystems.com> > Sent: Monday, January 30, 2023 1:45 PM > To: Sunil Kumar Kori <sk...@marvell.com>; Ankur Dwivedi > <adwiv...@marvell.com>; dev@dpdk.org > Cc: tho...@monjalon.net; david.march...@redhat.com; m...@ashroe.eu; > or...@nvidia.com; ferruh.yi...@amd.com; ch...@att.com; > humi...@huawei.com; linvi...@tuxdriver.com; ciara.lof...@intel.com; > qi.z.zh...@intel.com; m...@semihalf.com; m...@semihalf.com; > shaib...@amazon.com; evge...@amazon.com; igo...@amazon.com; > cha...@amd.com; Igor Russkikh <irussk...@marvell.com>; > shepard.sie...@atomicrules.com; ed.cz...@atomicrules.com; > john.mil...@atomicrules.com; ajit.khapa...@broadcom.com; > somnath.ko...@broadcom.com; Jerin Jacob Kollanukkaran > <jer...@marvell.com>; Maciej Czekaj [C] <mcze...@marvell.com>; Shijith > Thotton <sthot...@marvell.com>; Srisivasubramanian Srinivasan > <sriniva...@marvell.com>; Harman Kalra <hka...@marvell.com>; > rahul.lakkire...@chelsio.com; johnd...@cisco.com; hyon...@cisco.com; > liudongdo...@huawei.com; yisen.zhu...@huawei.com; > xuanziya...@huawei.com; cloud.wangxiao...@huawei.com; > zhouguoy...@huawei.com; simei...@intel.com; wenjun1...@intel.com; > qiming.y...@intel.com; yuying.zh...@intel.com; beilei.x...@intel.com; > xiao.w.w...@intel.com; jingjing...@intel.com; junfeng....@intel.com; > rosen...@intel.com; Nithin Kumar Dabilpuram > <ndabilpu...@marvell.com>; Kiran Kumar Kokkilagadda > <kirankum...@marvell.com>; Satha Koteswara Rao Kottidi > <skotesh...@marvell.com>; Liron Himi <lir...@marvell.com>; > z...@semihalf.com; Radha Chintakuntla <rad...@marvell.com>; > Veerasenareddy Burru <vbu...@marvell.com>; Sathesh B Edara > <sed...@marvell.com>; ma...@nvidia.com; viachesl...@nvidia.com; > lon...@microsoft.com; spin...@cesnet.cz; chaoyong...@corigine.com; > niklas.soderl...@corigine.com; hemant.agra...@nxp.com; > sachin.sax...@oss.nxp.com; g.si...@nxp.com; apeksha.gu...@nxp.com; > sachin.sax...@nxp.com; abo...@pensando.io; Rasesh Mody > <rm...@marvell.com>; Shahed Shaikh <shsha...@marvell.com>; Devendra > Singh Rawat <dsinghra...@marvell.com>; andrew.rybche...@oktetlabs.ru; > jiawe...@trustnetic.com; jianw...@trustnetic.com; > jbehr...@vmware.com; maxime.coque...@redhat.com; > chenbo....@intel.com; steven.webs...@windriver.com; > matt.pet...@windriver.com; bruce.richard...@intel.com; > mtetsu...@gmail.com; gr...@u256.net; jasvinder.si...@intel.com; > cristian.dumitre...@intel.com; jgraj...@cisco.com; Ankur Dwivedi > <adwiv...@marvell.com> > Subject: [EXT] RE: [PATCH v7 1/6] eal: trace: add trace point emit for blob > > External Email > > ---------------------------------------------------------------------- > > From: Sunil Kumar Kori [mailto:sk...@marvell.com] > > Sent: Monday, 30 January 2023 08.31 > > > > > From: Ankur Dwivedi <adwiv...@marvell.com> > > > Sent: Monday, January 23, 2023 2:32 PM > > > > > [...] > > > > +RTE_TRACE_POINT( > > > + rte_eal_trace_generic_blob, > > > + RTE_TRACE_POINT_ARGS(void *in, uint8_t len), > > > + rte_trace_point_emit_blob(in, len); > > > +) > > > + > > > > As per documentation rte_eal_trace_generic_blob() will emit 64 bytes > > only i.e. input array cannot be other than uint8_t. > > So will it not be better to make it more readable like > > RTE_TRACE_POINT_ARGS(uint8_t *in, uint8_t len) instead of using void > > *in. > > No. Using uint8_t* would cause type conversion problems. The advantage of > using void* is that it is has no type - which is exactly the purpose of a BLOB > (which is short for Binary Large OBject). We want to be able to pass a pointer > to e.g. a structure. Using void* makes that directly available. > > I didn't notice before, but the const qualifier is missing. It should be: > > RTE_TRACE_POINT_ARGS(const void *in, uint8_t len), >
Makes sense. Ack. > > > > Rest is fine. Already acked above. > > > > > #define RTE_EAL_TRACE_GENERIC_FUNC > > > rte_eal_trace_generic_func(__func__) > > > > > > /* Interrupt */ > > > > [snipped] > > > > > 2.25.1 > >