On 1/9/2023 5:36 PM, Tyler Retzlaff wrote: > Move existing bit manipulation, log and npow functions from > rte_common.h to rte_bitops.h > > Provide leading and trailing zero bit count functions to abstract away > compiler specific implementations. > > Include basic unit test for new leading/trailing zero bit count functions. > > v4: > * combine unit test commit into function addition commit > > v3: > * rename to use 32/64 instead of l/ll suffixes > * add new functions to rte_bitops.h instead of new header > * move other bit functions from rte_common.h to rte_bitops.h > > v2: > * use unsigned int instead of unsigned (checkpatches) > * match multiple include guard naming convention to rte_common.h > * add explicit extern "C" linkage to rte_bitcount.h > note: not really needed but checkpatches required > * add missing space around '-' > > Tyler Retzlaff (2): > eal: move bit operation functions from common to bitops header > eal: provide leading and trailing zero bit count abstraction >
There are checkpatch / checkgitlog errors, can you please check them: - checkpatches: ### [PATCH] eal: provide leading and trailing zero bit count abstraction WARNING:FROM_SIGN_OFF_MISMATCH: From:/Signed-off-by: email address mismatch: 'From: Tyler Retzlaff <roret...@microsoft.com>' != 'Signed-off-by: Tyler Retzlaff <roret...@linux.microsoft.com>' total: 0 errors, 1 warnings, 264 lines checked 1/2 valid patch - check-git-log: Headline too long: eal: move bit operation functions from common to bitops header