12/10/2022 17:16, Ankur Dwivedi: > > >-----Original Message----- > >From: Thomas Monjalon <tho...@monjalon.net> > >Sent: Wednesday, October 12, 2022 6:39 PM > >To: Ankur Dwivedi <adwiv...@marvell.com> > >Cc: dev@dpdk.org; Akhil Goyal <gak...@marvell.com>; > >royzhang1...@gmail.com; Amit Prakash Shukla <amitpraka...@marvell.com>; > >Jerin Jacob Kollanukkaran <jer...@marvell.com>; Ankur Dwivedi > ><adwiv...@marvell.com>; david.march...@redhat.com > >Subject: [EXT] Re: [PATCH v2] devtools: add tracepoint check in checkpatch > > > >External Email > > > >---------------------------------------------------------------------- > >12/10/2022 13:45, Ankur Dwivedi: > >> devtools/check-symbol-change.sh | 76 +------------------------------- > >> devtools/check-tracepoint.py | 52 ++++++++++++++++++++++ > >> devtools/check-tracepoint.sh | 66 ++++++++++++++++++++++++++++ > >> devtools/checkpatches.sh | 9 ++++ > >> devtools/common-func.sh | 77 +++++++++++++++++++++++++++++++++ > >> devtools/trace-skiplist.txt | 0 > > > >Before diving into this proposal, > >I would like a split of the patch for the rework (and move) of check-symbol- > >change.sh alone. > Will split the patch in next version. > > > >In general I see too many files added: > > check-tracepoint.py and check-tracepoint.sh common-func.sh is > >probably a bad name. > Regarding common-func.sh name, I am thinking of renaming it to common.sh or > helper.sh, considering there may be more common shell routines in future. > Otherwise it can be renamed to build-map.sh considering it will contain only > build_map_changes() function. > Please suggest a suitable name if my suggested names are bad. > > Will try to combine check-tracepoint.py and check-tracepoint.sh.
There are many very different scripts in devtools. Having a very common script won't work well. Please keep scripts specialized. If you need a script to check symbol, it should include "symbol" in its name.