On 10/28/21 14:38, David Marchand wrote:
On Thu, Oct 28, 2021 at 2:03 PM Maxime Coquelin
<maxime.coque...@redhat.com> wrote:
This patch marks the vDPA driver APIs as internal and
rename the corresponding header file.
Signed-off-by: Maxime Coquelin <maxime.coque...@redhat.com>
---
drivers/vdpa/ifc/ifcvf_vdpa.c | 2 +-
drivers/vdpa/mlx5/mlx5_vdpa.h | 2 +-
lib/vhost/meson.build | 4 +++-
lib/vhost/vdpa.c | 2 +-
lib/vhost/{rte_vdpa_dev.h => vdpa_dev.h} | 6 ++++++
It is more explicit it is a driver-only header if we rename as
vdpa_driver.h or vdpa_pmd.h.
Agree, I can take the opportunity to rename it to vdpa_driver.h.
[snip]
@@ -86,3 +82,12 @@ EXPERIMENTAL {
rte_vhost_async_channel_unregister_thread_unsafe;
rte_vhost_clear_queue_thread_unsafe;
};
+
+INTERNAL {
+ global;
+
+ rte_vdpa_register_device;
+ rte_vdpa_unregister_device;
+ rte_vhost_host_notifier_ctrl;
+ rte_vdpa_relay_vring_used;
+};
Alphabetical order, please.
Will do.
Please also add a note in the release notes.
Strictly speaking, this is an announced API change.
Cc: techboard.
Correct, I think we need a vote from the techboard.
@Techboard, this API change felt through the cracks.
Please note that the drivers APIs that are being marked as
internal were already moved in a dedicated header last year,
so any application are likely not using these APIs.
There is a patch for mlx5 vdpa that introduces a new entry
to struct rte_vdpa_dev_ops, so I think it would be better
to have these APIs marked as internal before mlx5 patch is
applied.
Thanks in advance,
Maxime
The rest lgtm.
Thanks.