> -----Original Message-----
> From: nipun.gu...@nxp.com <nipun.gu...@nxp.com>
> Sent: Tuesday, September 28, 2021 1:30 AM
> To: dev@dpdk.org; gak...@marvell.com; Chautru, Nicolas
> <nicolas.chau...@intel.com>
> Cc: david.march...@redhat.com; hemant.agra...@nxp.com; Nipun Gupta
> <nipun.gu...@nxp.com>
> Subject: [PATCH v7 1/9] bbdev: add big endian processing data processing
> info
>
> From: Nipun Gupta <nipun.gu...@nxp.com>
>
> This patch intoduces a new info pertaining to bbdev device to process the
> data in big endian order.
Typo in commit message
>
> Signed-off-by: Nipun Gupta <nipun.gu...@nxp.com>
> ---
> lib/bbdev/rte_bbdev.h | 2 ++
> 1 file changed, 2 insertions(+)
>
> diff --git a/lib/bbdev/rte_bbdev.h b/lib/bbdev/rte_bbdev.h index
> 7017124414..3acc008d06 100644
> --- a/lib/bbdev/rte_bbdev.h
> +++ b/lib/bbdev/rte_bbdev.h
> @@ -309,6 +309,8 @@ struct rte_bbdev_driver_info {
> uint16_t min_alignment;
> /** HARQ memory available in kB */
> uint32_t harq_buffer_size;
> + /** Device support input, output and HARQ data as big-endian */
> + uint8_t support_be_data;
Shouldn't this either be a bool or even better an enum?
Ie. as per rte_bbdev_op_cb_mode enum for instance
Having 0/1 magic number in the code will always be misleading
> /** Default queue configuration used if none is supplied */
> struct rte_bbdev_queue_conf default_queue_conf;
> /** Device operation capabilities */
> --
> 2.17.1