Cc maillist for history record.

On Thu, 2021-09-23 at 23:34 +0800, Xueming Li wrote:

Hi Min,


On Thu, 2021-09-23 at 17:15 +0800, Min Hu (Connor) wrote:

Hi, Xueming,

        Not only "rte_eth_devices[(hw)->data->port_id]" exist in HNS3 PMD, but

also "rte_eth_devices[rxq->port_id]", so marco which will be

added may be:

        #define HNS3_DEV(port_id) &rte_eth_devices[port_id]

call it like this:

  - hns3_dev_rx_queue_release(&rte_eth_devices[hw->data->port_id], i);

  + hns3_dev_rx_queue_release(HNS3_DEV(hw->data->port_id), i);


But this seems a little wired, what do you think ?


From usage, most of them are hw, some are rxq or txq.

How about rename HNS3_DEV(hw) to HNS3_HW_DEV(hw)?

Later, if needed, add HNS3_Q_DEV(q).




在 2021/9/23 14:22, Xueming(Steven) Li 写道:

Hi HNS3 maintainers,


In my ethdev patch below that changing ethdev queue release API, some

minor changes are expected on HNS3 pmd as well.


Since &rte_eth_devices[hw->data->port_id] is used a lot, A macro is

planned to hide direct rte_eth_devices access, please confirm the

changes below:


In drivers/net/hns3/hns3_ethdev.h:

   #define HNS3_DEV(hw) &rte_eth_devices[(hw)->data->port_id]

Call it like this:

   - hns3_dev_rx_queue_release(&rte_eth_devices[hw->data->port_id], i);

   + hns3_dev_rx_queue_release(HNS3_DEV(hw), i);


There are more directly access to rte_eth_devices in hns3 PMD, you can

changes them later.


Please confirm or suggest if any.


Best Regards,

Xueming Li



-------- Forwarded Message --------

From: Ferruh Yigit <ferruh.yi...@intel.com<mailto:ferruh.yi...@intel.com>>

To: Xueming(Steven) Li <xuemi...@nvidia.com<mailto:xuemi...@nvidia.com>>, 
yisen.zhu...@huawei.com<mailto:yisen.zhu...@huawei.com>

<yisen.zhu...@huawei.com<mailto:yisen.zhu...@huawei.com>>, 
ouli...@huawei.com<mailto:ouli...@huawei.com> 
<ouli...@huawei.com<mailto:ouli...@huawei.com>>,

dev@dpdk.org<mailto:dev@dpdk.org> <dev@dpdk.org<mailto:dev@dpdk.org>>, 
humi...@huawei.com<mailto:humi...@huawei.com> 
<humi...@huawei.com<mailto:humi...@huawei.com>>,

spin...@cesnet.cz<mailto:spin...@cesnet.cz> 
<spin...@cesnet.cz<mailto:spin...@cesnet.cz>>

Cc: zhouguoy...@huawei.com<mailto:zhouguoy...@huawei.com> 
<zhouguoy...@huawei.com<mailto:zhouguoy...@huawei.com>>,

mcze...@marvell.com<mailto:mcze...@marvell.com> 
<mcze...@marvell.com<mailto:mcze...@marvell.com>>, 
rad...@marvell.com<mailto:rad...@marvell.com>

<rad...@marvell.com<mailto:rad...@marvell.com>>, 
sthot...@marvell.com<mailto:sthot...@marvell.com> 
<sthot...@marvell.com<mailto:sthot...@marvell.com>>,

Matan Azrad <ma...@nvidia.com<mailto:ma...@nvidia.com>>, 
kirankum...@marvell.com<mailto:kirankum...@marvell.com>

<kirankum...@marvell.com<mailto:kirankum...@marvell.com>>, 
rm...@marvell.com<mailto:rm...@marvell.com> 
<rm...@marvell.com<mailto:rm...@marvell.com>>,

beilei.x...@intel.com<mailto:beilei.x...@intel.com> 
<beilei.x...@intel.com<mailto:beilei.x...@intel.com>>, 
chenbo....@intel.com<mailto:chenbo....@intel.com>

<chenbo....@intel.com<mailto:chenbo....@intel.com>>, 
vbu...@marvell.com<mailto:vbu...@marvell.com> 
<vbu...@marvell.com<mailto:vbu...@marvell.com>>,

somnath.ko...@broadcom.com<mailto:somnath.ko...@broadcom.com> 
<somnath.ko...@broadcom.com<mailto:somnath.ko...@broadcom.com>>,

jiawe...@trustnetic.com<mailto:jiawe...@trustnetic.com> 
<jiawe...@trustnetic.com<mailto:jiawe...@trustnetic.com>>, 
sk...@marvell.com<mailto:sk...@marvell.com>

<sk...@marvell.com<mailto:sk...@marvell.com>>, 
hemant.agra...@nxp.com<mailto:hemant.agra...@nxp.com> 
<hemant.agra...@nxp.com<mailto:hemant.agra...@nxp.com>>,

maxime.coque...@redhat.com<mailto:maxime.coque...@redhat.com> 
<maxime.coque...@redhat.com<mailto:maxime.coque...@redhat.com>>,

heinrich.k...@corigine.com<mailto:heinrich.k...@corigine.com> 
<heinrich.k...@corigine.com<mailto:heinrich.k...@corigine.com>>,

asoma...@amd.com<mailto:asoma...@amd.com> 
<asoma...@amd.com<mailto:asoma...@amd.com>>, 
andrew.rybche...@oktetlabs.ru<mailto:andrew.rybche...@oktetlabs.ru>

<andrew.rybche...@oktetlabs.ru<mailto:andrew.rybche...@oktetlabs.ru>>, 
yongw...@vmware.com<mailto:yongw...@vmware.com>

<yongw...@vmware.com<mailto:yongw...@vmware.com>>, 
ajit.khapa...@broadcom.com<mailto:ajit.khapa...@broadcom.com>

<ajit.khapa...@broadcom.com<mailto:ajit.khapa...@broadcom.com>>, 
hka...@marvell.com<mailto:hka...@marvell.com> 
<hka...@marvell.com<mailto:hka...@marvell.com>>,

shaib...@amazon.com<mailto:shaib...@amazon.com> 
<shaib...@amazon.com<mailto:shaib...@amazon.com>>, 
ch...@att.com<mailto:ch...@att.com>

<ch...@att.com<mailto:ch...@att.com>>, 
cloud.wangxiao...@huawei.com<mailto:cloud.wangxiao...@huawei.com>

<cloud.wangxiao...@huawei.com<mailto:cloud.wangxiao...@huawei.com>>, 
sthem...@microsoft.com<mailto:sthem...@microsoft.com>

<sthem...@microsoft.com<mailto:sthem...@microsoft.com>>, 
jer...@marvell.com<mailto:jer...@marvell.com> 
<jer...@marvell.com<mailto:jer...@marvell.com>>,

qiming.y...@intel.com<mailto:qiming.y...@intel.com> 
<qiming.y...@intel.com<mailto:qiming.y...@intel.com>>, 
pna...@marvell.com<mailto:pna...@marvell.com>

<pna...@marvell.com<mailto:pna...@marvell.com>>, NBU-Contact-Thomas Monjalon

<tho...@monjalon.net<mailto:tho...@monjalon.net>>, 
m...@semihalf.com<mailto:m...@semihalf.com> 
<m...@semihalf.com<mailto:m...@semihalf.com>>,

sriniva...@marvell.com<mailto:sriniva...@marvell.com> 
<sriniva...@marvell.com<mailto:sriniva...@marvell.com>>, 
m...@semihalf.com<mailto:m...@semihalf.com>

<m...@semihalf.com<mailto:m...@semihalf.com>>, 
keith.wi...@intel.com<mailto:keith.wi...@intel.com> 
<keith.wi...@intel.com<mailto:keith.wi...@intel.com>>,

xiao.w.w...@intel.com<mailto:xiao.w.w...@intel.com> 
<xiao.w.w...@intel.com<mailto:xiao.w.w...@intel.com>>, 
xuanziya...@huawei.com<mailto:xuanziya...@huawei.com>

<xuanziya...@huawei.com<mailto:xuanziya...@huawei.com>>, 
mtetsu...@gmail.com<mailto:mtetsu...@gmail.com> 
<mtetsu...@gmail.com<mailto:mtetsu...@gmail.com>>,

qi.z.zh...@intel.com<mailto:qi.z.zh...@intel.com> 
<qi.z.zh...@intel.com<mailto:qi.z.zh...@intel.com>>, 
g.si...@nxp.com<mailto:g.si...@nxp.com>

<g.si...@nxp.com<mailto:g.si...@nxp.com>>, 
abo...@pensando.io<mailto:abo...@pensando.io> 
<abo...@pensando.io<mailto:abo...@pensando.io>>,

steven.webs...@windriver.com<mailto:steven.webs...@windriver.com> 
<steven.webs...@windriver.com<mailto:steven.webs...@windriver.com>>,

evge...@amazon.com<mailto:evge...@amazon.com> 
<evge...@amazon.com<mailto:evge...@amazon.com>>, 
johnd...@cisco.com<mailto:johnd...@cisco.com>

<johnd...@cisco.com<mailto:johnd...@cisco.com>>, 
irussk...@marvell.com<mailto:irussk...@marvell.com> 
<irussk...@marvell.com<mailto:irussk...@marvell.com>>,

dsinghra...@marvell.com<mailto:dsinghra...@marvell.com> 
<dsinghra...@marvell.com<mailto:dsinghra...@marvell.com>>, 
shsha...@marvell.com<mailto:shsha...@marvell.com>

<shsha...@marvell.com<mailto:shsha...@marvell.com>>, 
lir...@marvell.com<mailto:lir...@marvell.com> 
<lir...@marvell.com<mailto:lir...@marvell.com>>, Slava

Ovsiienko <viachesl...@nvidia.com<mailto:viachesl...@nvidia.com>>, 
aman.deep.si...@intel.com<mailto:aman.deep.si...@intel.com>

<aman.deep.si...@intel.com<mailto:aman.deep.si...@intel.com>>, 
sachin.sax...@oss.nxp.com<mailto:sachin.sax...@oss.nxp.com>

<sachin.sax...@oss.nxp.com<mailto:sachin.sax...@oss.nxp.com>>, 
rahul.lakkire...@chelsio.com<mailto:rahul.lakkire...@chelsio.com>

<rahul.lakkire...@chelsio.com<mailto:rahul.lakkire...@chelsio.com>>, 
matt.pet...@windriver.com<mailto:matt.pet...@windriver.com>

<matt.pet...@windriver.com<mailto:matt.pet...@windriver.com>>, 
jianw...@trustnetic.com<mailto:jianw...@trustnetic.com>

<jianw...@trustnetic.com<mailto:jianw...@trustnetic.com>>, 
skotesh...@marvell.com<mailto:skotesh...@marvell.com>

<skotesh...@marvell.com<mailto:skotesh...@marvell.com>>, 
z...@semihalf.com<mailto:z...@semihalf.com> 
<z...@semihalf.com<mailto:z...@semihalf.com>>, NBU-

Contact-longli <lon...@microsoft.com<mailto:lon...@microsoft.com>>, 
jingjing...@intel.com<mailto:jingjing...@intel.com>

<jingjing...@intel.com<mailto:jingjing...@intel.com>>, 
igo...@amazon.com<mailto:igo...@amazon.com> 
<igo...@amazon.com<mailto:igo...@amazon.com>>,

gr...@u256.net<mailto:gr...@u256.net> <gr...@u256.net<mailto:gr...@u256.net>>, 
haiyue.w...@intel.com<mailto:haiyue.w...@intel.com>

<haiyue.w...@intel.com<mailto:haiyue.w...@intel.com>>, 
jgraj...@cisco.com<mailto:jgraj...@cisco.com> 
<jgraj...@cisco.com<mailto:jgraj...@cisco.com>>,

hyon...@cisco.com<mailto:hyon...@cisco.com> 
<hyon...@cisco.com<mailto:hyon...@cisco.com>>, 
ndabilpu...@marvell.com<mailto:ndabilpu...@marvell.com>

<ndabilpu...@marvell.com<mailto:ndabilpu...@marvell.com>>

Subject: Re: [PATCH v5 2/2] ethdev: change queue release callback

Date: Wed, 22 Sep 2021 11:57:54 +0100


<...>


@@ -1536,7 +1536,8 @@ hns3_fake_rx_queue_config(struct hns3_hw *hw, uint16_t 
nb_queues)

                /* re-configure */

                rxq = hw->fkq_data.rx_queues;

                for (i = nb_queues; i < old_nb_queues; i++)

-                       hns3_dev_rx_queue_release(rxq[i]);

+                       hns3_dev_rx_queue_release

+                               (&rte_eth_devices[hw->data->port_id], i);


I think this should be done without driver accesing the global 'rte_eth_devices'

array. This may require more help from driver maintainer, and perhaps wrapper

functions can be used for the driver for now and maintainer can update it later,

if agreed with the driver maintainer.


There are about 20 direct accessing to the global 'rte_eth_devices',


I already made similar comment to the driver previously, but lets just not add

more usage.


I'm afraid adding more patches to improve PMD drivers might make this

patcheset over complex.



Agree to not complex this patch for it.


Huawei maintainers, could you please address Ferruh's suggestion? just

a clean up whith simple macro.


@Min Hu (Connor) <humi...@huawei.com<mailto:humi...@huawei.com>>

@Yisen Zhuang <yisen.zhu...@huawei.com<mailto:yisen.zhu...@huawei.com>>

@Lijun Ou <ouli...@huawei.com<mailto:ouli...@huawei.com>>





Reply via email to