On Tue, Jun 29, 2021 at 12:55:05PM +0200, Juraj Linkeš wrote: > Add an option to automatically discover the host's numa and cpu counts > and use those values for a non cross-build. > Give users the option to override the per-arch default values or values > from cross files by specifying them on the command line with -Dmax_lcores > and -Dmax_numa_nodes. > > Signed-off-by: Juraj Linkeš <juraj.lin...@pantheon.tech> > Reviewed-by: Honnappa Nagarahalli <honnappa.nagaraha...@arm.com> > --- Two very minor suggestions inline below.
Acked-by: Bruce Richardson <bruce.richard...@intel.com> > <snip> > +max_lcores = get_option('max_lcores') > +if max_lcores == 'auto' Rather than "auto", would "detect" be a clearer name for this option value? <snip> > +option('max_lcores', type: 'string', value: 'default', description: > + 'Set maximum number of cores/threads supported by EAL. The default is > different per-arch. Set to auto to detect the number of cores on the build > machine.') > +option('max_numa_nodes', type: 'string', value: 'default', description: > + 'Set highest NUMA node supported by EAL. The default is different > per-arch. Set to auto to detect the highest numa node on the build machine.') I'd put the explicit values of "default" and "auto"(or "detect") in quotes "" to make clear they are literal values.