On 4/29/21 11:10 AM, Raslan Darawsheh wrote: > Define new rte header for gtp PDU session container > based on RFC 38415-g30 > > Signed-off-by: Raslan Darawsheh <rasl...@nvidia.com> > --- > lib/net/rte_gtp.h | 78 +++++++++++++++++++++++++++++++++++++++++++++++ > 1 file changed, 78 insertions(+) > > diff --git a/lib/net/rte_gtp.h b/lib/net/rte_gtp.h > index 6a6f9b238d..5a850a26e4 100644 > --- a/lib/net/rte_gtp.h > +++ b/lib/net/rte_gtp.h > @@ -61,6 +61,84 @@ struct rte_gtp_hdr_ext_word { > uint8_t next_ext; /**< Next Extension Header Type. */ > } __rte_packed; > > +/** > + * Optional extension for GTP with next_ext set to 0x85 > + * defined based on RFC 38415-g30. > + */ > +__extension__ > +struct rte_gtp_psc_generic_hdr { > + uint8_t ext_hdr_len; /**< PDU ext hdr len in multiples of 4 bytes */ > +#if RTE_BYTE_ORDER == RTE_BIG_ENDIAN > + uint8_t type:4; /**< PDU type */ > + uint8_t qmp:1; /**< Qos Monitoring Packet */ > + uint8_t pad:3; /**< type specfic pad bits */ > + uint8_t spare:2; /**< type specific spare bits */ > + uint8_t qfi:6; /**< Qos Flow Identifier */ > +#else > + uint8_t qfi:6; /**< Qos Flow Identifier */ > + uint8_t spare:2; /**< type specific spare bits */ > + uint8_t pad:3; /**< type specfic pad bits */ > + uint8_t qmp:1; /**< Qos Monitoring Packet */ > + uint8_t type:4; /**< PDU type */ > +#endif > + uint8_t data[0]; /**< variable length data feilds */ > +} __rte_packed; > + > +/** > + * Optional extension for GTP with next_ext set to 0x85 > + * type0 defined based on RFC 38415-g30 > + */ > +__extension__ > +struct rte_gtp_psc_type0_hdr { > + uint8_t ext_hdr_len; /**< PDU ext hdr len in multiples of 4 bytes */ > +#if RTE_BYTE_ORDER == RTE_BIG_ENDIAN > + uint8_t type:4; /**< PDU type */ > + uint8_t qmp:1; /**< Qos Monitoring Packet */ > + uint8_t snp:1; /**< Sequence number presence */ > + uint8_t spare_dl1:2; /**< spare down link bits */ > + uint8_t ppp:1; /**< Paging policy presence */ > + uint8_t rqi:1; /**< Reflective Qos Indicator */ > + uint8_t qfi:6; /**< Qos Flow Identifier */ > +#else > + uint8_t qfi:6; /**< Qos Flow Identifier */ > + uint8_t rqi:1; /**< Reflective Qos Indicator */ > + uint8_t ppp:1; /**< Paging policy presence */ > + uint8_t spare_dl1:2; /**< spare down link bits */ > + uint8_t snp:1; /**< Sequence number presence */ > + uint8_t type:4; /**< PDU type */ > +#endif > + uint8_t data[0]; /**< variable length data feilds */ > +} __rte_packed; > + > +/** > + * Optional extension for GTP with next_ext set to 0x85 > + * type1 defined based on RFC 38415-g30 > + */ > +__extension__ > +struct rte_gtp_psc_type1_hdr { > + uint8_t ext_hdr_len; /**< PDU ext hdr len in multiples of 4 bytes */ > +#if RTE_BYTE_ORDER == RTE_BIG_ENDIAN > + uint8_t type:4; /**< PDU type */ > + uint8_t qmp:1; /**< Qos Monitoring Packet */ > + uint8_t dl_delay_ind:1; /**< dl delay result presence */ > + uint8_t ul_delay_ind:1; /**< ul delay result presence */ > + uint8_t snp:1; /**< Sequence number presence ul */ > + uint8_t n_delay_ind:1; /**< N3/N9 delay result presence */ > + uint8_t spare_ul2:1; /**< spare up link bits */ > + uint8_t qfi:6; /**< Qos Flow Identifier */ > +#else > + uint8_t qfi:6; /**< Qos Flow Identifier */ > + uint8_t spare_ul2:1; /**< spare up link bits */ > + uint8_t n_delay_ind:1; /**< N3/N9 delay result presence */ > + uint8_t snp:1; /**< Sequence number presence ul */ > + uint8_t ul_delay_ind:1; /**< ul delay result presence */ > + uint8_t dl_delay_ind:1; /**< dl delay result presence */ > + uint8_t qmp:1; /**< Qos Monitoring Packet */ > + uint8_t type:4; /**< PDU type */ > +#endif > + uint8_t data[0]; /**< variable length data feilds */ > +} __rte_packed; > + > /** GTP header length */ > #define RTE_ETHER_GTP_HLEN \ > (sizeof(struct rte_udp_hdr) + sizeof(struct rte_gtp_hdr)) >
This way the structure is very hard to read. May I ask to indent field comments as it is done in other rte_net structures (e.g. rte_ipv4_hdr, rte_udp_hdr, rte_geneve_hdr). Personally I don't care if it will be indent by TABs or spaces, however, it looks like TABs are used in more places.