On 3/3/2021 10:51 PM, Dmitry Kozlyuk wrote: > It is proposed to rename fields of `struct rte_ether_hdr`, > `s_addr` tp `src_addr` and `d_addr` to `dst_addr`,
s/tp/to/ > due to the clash with system macro on Windows. > Until remaining is done in 21.11, a workaround can be used. s/remaining/renaming/ ?? > > Windows Sockets headers contain `#define s_addr S_un.S_addr`, which > conflicts with `s_addr` field of `struct rte_ether_hdr`. Undefining > this macro in <rte_ether.h> is breaking some usages of DPDK > and Windows headers in one file. > > Example 1: > > #include <winsock2.h> > #include <rte_ether.h> > struct in_addr addr; > /* addr.s_addr = 0; ERROR: s_addr undefined by DPDK */ > > Example 2: > > #include <rte_ether.h> > #include <winsock2.h> > struct rte_ether_hdr eh; > /* eh.s_addr.addr_bytes[0] = 0; ERROR: `addr_s` is a macro */ s/addr_s/s_addr/ ?? > > It is not mandatory to rename `d_addr`, this is for consistency only. > Naming in `rte_ether_hdr` will also resemble `rte_ipv4/6_hdr`. > > Workaround is to define `struct rte_ether_hdr` in such a away that > it can be used with or without `s_addr` macro (as defined on Windows) > This can be done for Windows only or for all platforms to save space. > > #pragma push_macro("s_addr") > #ifdef s_addr > #undef s_addr > #endif > > struct rte_ether_hdr { > struct rte_ether_addr d_addr; /**< Destination address. */ > RTE_STD_C11 > union { > struct rte_ether_addr s_addr; /**< Source address. */ > struct { > struct rte_ether_addr S_un; > /**< MUST NOT be used directly, only via s_addr */ > } S_addr; > /*< MUST NOT be used directly, only via s_addr */ > }; > uint16_t ether_type; /**< Frame type. */ > } __rte_aligned(2); > > #pragma pop_macro("s_addr") > What is the problem with the workaround, why we can't live with it? It requires an order in include files, right? > Signed-off-by: Dmitry Kozlyuk <dmitry.kozl...@gmail.com> > --- > doc/guides/rel_notes/deprecation.rst | 4 ++++ > 1 file changed, 4 insertions(+) > > diff --git a/doc/guides/rel_notes/deprecation.rst > b/doc/guides/rel_notes/deprecation.rst > index 82c1a90a3..f7be10543 100644 > --- a/doc/guides/rel_notes/deprecation.rst > +++ b/doc/guides/rel_notes/deprecation.rst > @@ -125,3 +125,7 @@ Deprecation Notices > * cmdline: ``cmdline`` structure will be made opaque to hide > platform-specific > content. On Linux and FreeBSD, supported prior to DPDK 20.11, > original structure will be kept until DPDK 21.11. > + > +* net: ``s_addr`` and ``d_addr`` fields of ``rte_ether_hdr`` structure > + will be renamed to ``src_addr`` and ``dst_addr`` respectively in DPDK 20.11 v21.11 > + in order to avoid conflict with Windows Sockets headers. >