15/04/2021 10:25, Bruce Richardson: > On Thu, Apr 15, 2021 at 09:26:38AM +0200, David Marchand wrote: > > On Thu, Apr 15, 2021 at 7:33 AM Akhil Goyal <gak...@marvell.com> wrote: > > > > > +; Ignore changes in reserved fields > > > > > +[suppress_variable] > > > > > + name_regexp = reserved > > > > > > > > Mm, this rule is a bit scary, as it matches anything with "reserved" in > > > > it. > > > > > > Why do you feel it is scary? Reserved is something which may change at > > > any time > > > Just like experimental. Hence creating a generic exception rule for it > > > make sense > > > And it is done intentionally in this patch. > > > > The reserved regexp on the name of a variable / struct field is too lax. > > Anything could be named with reserved in it. > > If we have clear patterns, they must be preferred, like (untested) > > name_regexp = ^reserved_(64|ptr)s$ > > > +1 to have a clear name. I would suggest using a "__reserved" prefix, since > no real field name should ever start with that prefix.
+1 for the double underscore Changing it now does not break API as it is not supposed to be used.