Hi, Currently most of the build options are duplicated in 2 config files. They should be merged in a common file to avoid this kind of differences:
--- config/common_bsdapp +++ config/common_linuxapp -CONFIG_RTE_IXGBE_INC_VECTOR=n +CONFIG_RTE_IXGBE_INC_VECTOR=y -CONFIG_RTE_IXGBE_RX_OLFLAGS_DISABLE=n +CONFIG_RTE_IXGBE_RX_OLFLAGS_ENABLE=y -CONFIG_RTE_LIBRTE_I40E_RX_ALLOW_BULK_ALLOC=n +CONFIG_RTE_LIBRTE_I40E_RX_ALLOW_BULK_ALLOC=y Can we enable ixgbe SSE on BSD? CONFIG_RTE_IXGBE_RX_OLFLAGS_DISABLE must be renamed to CONFIG_RTE_IXGBE_RX_OLFLAGS_ENABLE, or can we remove this option? Can we remove i40e bulk alloc option? Why IEEE1588 is disabled? Can we remove this option? Please help to fix it for the release 2.1. After fixing the config, we have to think about simplifying it in 2.2. It would be easier to have some kind of config overlays: config_base config_bsd config_linux config_osv config_gcc config_icc config_clang config_i686 config_x86_64 config_x86_x32 config_ppc_64 config_tile-tilegx Then the defconfig files would include the above files. Or better, we could allow some paramaters to make config: make config ARCH= OS= CC= Thoughts?