On Fri, Mar 12, 2021 at 04:52:05PM +0100, Thomas Monjalon wrote: > 12/03/2021 16:34, Bruce Richardson: > > > > > > > > Instead of adding the "get_option('enable_driver_sdk')" checks to the > > > > modules, > > > > what about a more generic solution, like: > > > > > > > > modules assign relevant headers into a new variable, let's say > > > > 'pmd_headers', > > > > and in a high level meson file, all 'pmd_headers' are installed if > > > > 'enable_driver_sdk' enabled? > > > > > > > > > > +1. > > > Just, I don't like "pmd_headers" as the list name. > > > It can be misunderstood as the list of pmd-specific headers (thinking > > > of rte_pmd_i40e.h), that are exposed to applications. > > > > > Since the option is called "enable_driver_sdk" the variable name of > > "driver_sdk_headers" would be a good match. We should try and keep variable > > names and option names in sync as much as possible. > > +1 >
seems like there is consensus. i'll figure out how introduce a driver_sdk_headers variable generically and remove the per-meson.build conditional evaluation. thanks