Hi, > -----Original Message----- > From: dev <dev-boun...@dpdk.org> On Behalf Of Dekel Peled > Sent: Monday, February 1, 2021 11:29 AM > To: Matan Azrad <ma...@nvidia.com>; Shahaf Shuler > <shah...@nvidia.com>; Slava Ovsiienko <viachesl...@nvidia.com> > Cc: dev@dpdk.org; sta...@dpdk.org > Subject: [dpdk-dev] [PATCH] net/mlx5: fix shared RSS translation and > cleanup > > This patch includes several updates of the shared RSS action: > > (1) > The shared RSS action, introduced recently, uses existing definitions > of the regular RSS action. > The new defined value MLX5_RSS_HASH_IPV4_TCP uses existing definition > IBV_RX_HASH_SRC_PORT_TCP twice, instead of using > IBV_RX_HASH_SRC_PORT_TCP and IBV_RX_HASH_DST_PORT_TCP. > --- --- > The same is true for IPv4-UDP, IPv6-TCP, IPv6-UDP. > As result, a shared RSS action with L4 type is specified as src-only. > Flow rule using such shared action, while specifying L4 item in flow > pattern, will fail to create. > This patch updates the new definitions, to use the existing values > correctly. > > (2) > On shared RSS action destroy, in function __flow_dv_action_rss_release, > the indirection table shared_rss->ind_tbl was released before > shared_rss->refcnt was checked. > This order is incorrect, since the indirection table should be > released only when the shared RSS action is destroyed. > This patch puts release function calls in correct order. > > (3) > Variables declared of type "struct mlx5_shared_action_rss" are named > "shared_rss", "action", and "shared_action". > To improve code readability, this patch renames all to "shared_rss". > > Fixes: d7cfcddded61 ("net/mlx5: translate shared action for RSS action") > Fixes: d2046c09aa64 ("net/mlx5: support shared action for RSS") > Cc: sta...@dpdk.org > > Signed-off-by: Dekel Peled <dek...@nvidia.com> > Acked-by: Matan Azrad <ma...@nvidia.com>
Patch applied to next-net-mlx, Kindest regards, Raslan Darawsheh