On Wed, 22 Jul 2015 19:28:51 +0100 Konstantin Ananyev <konstantin.ananyev at intel.com> wrote:
> Add the ability for the upper layer to query RX/TX queue information. > > Add new structures: > struct rte_eth_rxq_info > struct rte_eth_txq_info > > new functions: > rte_eth_rx_queue_info_get > rte_eth_tx_queue_info_get > > into rte_etdev API. > > Left extra free space in the queue info structures, > so extra fields could be added later without ABI breakage. > > v2 changes: > - Add formal check for the qinfo input parameter. > - As suggested rename 'rx_qinfo/tx_qinfo' to 'rxq_info/txq_info' > > v3 changes: > - Updated rte_ether_version.map > - Merged with latest changes > > v4 changes: > - rte_ether_version.map: move new functions into DPDK_2.1 sub-space. > > Signed-off-by: Konstantin Ananyev <konstantin.ananyev at intel.com> Since all this data should be rxconf already, Is it possible to do a generic version of this and not have to change every driver. You only handled the Intel hardware drivers. But there also all the virtual drivers, other vendors etc.