On 20/1/2021 2:27 PM, Burakov, Anatoly wrote:
On 20-Jan-21 1:55 PM, David Hunt wrote:
From: Bruce Richardson <bruce.richard...@intel.com>

rename the public structs to have an rte_power_ prefix.

Fixes: 210c383e247b ("power: packet format for vm power management")
Fixes: cd0d5547e873 ("power: vm communication channels in guest")
Cc: sta...@dpdk.org

Signed-off-by: Bruce Richardson <bruce.richard...@intel.com>
Signed-off-by: David Hunt <david.h...@intel.com>
---

<snip>

          RTE_LOG(ERR, GUEST_CLI, "Error receiving message.\n");
@@ -293,14 +294,15 @@ cmd_query_caps_list_parsed(void *parsed_result,
  {
      struct cmd_query_caps_result *res = parsed_result;
      unsigned int lcore_id;
-    struct channel_packet_caps_list pkt_caps_list;
-    struct channel_packet pkt;
+    struct rte_power_channel_packet_caps_list pkt_caps_list;
+    struct rte_power_channel_packet pkt;
      bool query_list = false;
      int ret;
      char *ep;
  -    memset(&pkt, 0, sizeof(struct channel_packet));
-    memset(&pkt_caps_list, 0, sizeof(struct channel_packet_caps_list));
+    memset(&pkt, 0, sizeof(struct rte_power_channel_packet));
+    memset(&pkt_caps_list, 0,
+            sizeof(struct rte_power_channel_packet_caps_list));

Here and in other places where you do sizeof(), you might want to avoid future changes by replacing it with sizeof(*pkt) instead?


Good point. Will do.

Thanks.

Reply via email to