> Subject: [PATCH v4 7/8] build: standardize component names and defines > > As discussed on the dpdk-dev mailing list[1], we can make some easy > improvements in standardizing the naming of the various components in > DPDK, and their associated feature-enabled macros. > > Following this patch, each library will have the name in format, > 'librte_<name>.so', and the macro indicating that library is enabled in the > build will have the form 'RTE_LIB_<NAME>'. > > Similarly, for libraries, the equivalent name formats and macros are: > 'librte_<class>_<name>.so' and 'RTE_<CLASS>_<NAME>', where class is the > device type taken from the relevant driver subdirectory name, i.e. 'net', > 'crypto' etc. > > To avoid too many changes at once for end applications, the old macro > names will still be provided in the build in this release, but will be removed > subsequently. > > Signed-off-by: Bruce Richardson <bruce.richard...@intel.com> >
Reviewed-by: Rosen Xu <rosen...@intel.com>