> > +static inline void > > +flow_lock(struct rte_eth_dev *dev) > > Maybe change the name to flow_safe_enter > Since this function doesn't always lock. I feel fts_enter() sounds better.
> > > +{ > > + if (!(dev->data->dev_flags & > > RTE_ETH_DEV_FLOW_OPS_THREAD_SAFE)) > > + pthread_mutex_lock(&dev->data->fts_mutex); > > +} > > + > > +static inline void > > +flow_unlock(struct rte_eth_dev *dev) > > Maybe change the name flow_safe_leave > Same reason as above. On the same lines.. fts_exit()