On 9/14/2020 4:05 AM, Zhirun Yan wrote: > The original set conf function in FDIR was very long. Refactor to > increase readability to make it clearer and allow for more convenient > further changes. > > No functional change here. > > Signed-off-by: Zhirun Yan <zhirun....@intel.com> > --- > drivers/net/ice/ice_fdir_filter.c | 54 ++++++++++++++++++------------- > 1 file changed, 31 insertions(+), 23 deletions(-) > > diff --git a/drivers/net/ice/ice_fdir_filter.c > b/drivers/net/ice/ice_fdir_filter.c > index 88c9bb03d..593dfd0e2 100644 > --- a/drivers/net/ice/ice_fdir_filter.c > +++ b/drivers/net/ice/ice_fdir_filter.c > @@ -964,30 +964,10 @@ ice_fdir_input_set_parse(uint64_t inset, enum > ice_flow_field *field) > } > } > > -static int > -ice_fdir_input_set_conf(struct ice_pf *pf, enum ice_fltr_ptype flow, > - uint64_t input_set, enum ice_fdir_tunnel_type ttype) > +static void > +ice_fdir_input_set_hdrs(enum ice_fltr_ptype flow, struct ice_flow_seg_info > *seg, > + enum ice_fdir_tunnel_type ttype) > {
Hi Zhirun, 'ttype' variable is not used in this function at all, what do you think removing it?