On 8/24/2020 10:51 PM, Ed Czeck wrote: > On Mon, Aug 24, 2020 at 10:55 AM Ferruh Yigit <ferruh.yi...@intel.com> wrote: >> >> On 8/24/2020 2:36 PM, Ed Czeck wrote: >>> Replace behavior with RTE_LIBRTE_ARK_MIN_TX_PKTLEN >>> with a default value of 0. >>> Update documentation as needed. >>> >>> Signed-off-by: Ed Czeck <ed.cz...@atomicrules.com> >>> --- >>> doc/guides/nics/ark.rst | 13 ++++++++-- >>> drivers/net/ark/ark_ethdev_tx.c | 44 +++++++++++++++++++-------------- >>> drivers/net/ark/ark_logs.h | 8 ------ >>> 3 files changed, 36 insertions(+), 29 deletions(-) >>> >>> diff --git a/doc/guides/nics/ark.rst b/doc/guides/nics/ark.rst >>> index c3ffcbbc2..f4d4539e5 100644 >>> --- a/doc/guides/nics/ark.rst >>> +++ b/doc/guides/nics/ark.rst >>> @@ -129,8 +129,10 @@ Configuration Information >>> * **CONFIG_RTE_LIBRTE_ARK_PMD** (default y): Enables or disables >>> inclusion >>> of the ARK PMD driver in the DPDK compilation. >>> >>> - * **CONFIG_RTE_LIBRTE_ARK_PAD_TX** (default y): When enabled TX >>> - packets are padded to 60 bytes to support downstream MACS. >>> + * **CONFIG_RTE_LIBRTE_ARK_MIN_TX_PKTLEN** (default 0): Sets the minimum >>> + packet length for tx packets to the FPGA. Packets less than this >>> + length are padded to meet the requirement. This allows padding to >>> + be offloaded or remain in host software. >>> >> >> There is no 'CONFIG_RTE_LIBRTE_ARK_MIN_TX_PKTLEN' option, I think it is >> confusing to add it to documentation. There is already some documentation in >> below for 'RTE_LIBRTE_ARK_MIN_TX_PKTLEN', what do you think removing this >> part? >> > Should I remove the all references to the CONFIG_RTE_LIBRTE_ARK from > the net/ark section of the guide? It appears that CONFIG_.* will be > removed along with the makefile build system.
As you said it is removed by Ciara's patch, no need to touch it in this patch. > >> And can you please remove 'CONFIG_RTE_LIBRTE_ARK_PAD_TX' form >> 'config/common_base'? >> > I am hesitant to modify config/common_base, since it is slated for > removal and edits will cause merge conflicts. Are you OK with this? OK. > >> Another option is, do you think does it help your users to keep the config >> name >> same, like keep the 'CONFIG_RTE_LIBRTE_ARK_PAD_TX' as 'RTE_LIBRTE_ARK_PAD_TX' >> for the meson CFLAGs, instead of renaming it to >> 'RTE_LIBRTE_ARK_MIN_TX_PKTLEN'? > I will drop the CONFIG names and leave the compiler marco documented > in my next patch. > OK, thanks.