On 01-Jul-20 9:23 PM, Stephen Hemminger wrote:
Replace the old use of master/slave lcore with more inclusive
name of initial/secondary lcore. The old visible API will
stay for now.
Change master2slave to new init2worker and vice-versa.
This patch breaks the expected practice for new API's.
The new rte_get_initial_lcore() will not go through the standard
experimental API phase; there is no functional difference
from the previous name.
Signed-off-by: Stephen Hemminger <step...@networkplumber.org>
---
It's more difficult than it needs to be to review this patchset as it's
out of date with current code.
diff --git a/doc/guides/nics/memif.rst b/doc/guides/nics/memif.rst
index ddeebed25ccd..9c67d7141cbe 100644
--- a/doc/guides/nics/memif.rst
+++ b/doc/guides/nics/memif.rst
@@ -106,13 +106,13 @@ region n (no-zero-copy):
+-----------------------+-------------------------------------------------------------------------+
| Rings | Buffers
|
+-----------+-----------+-----------------+---+---------------------------------------------------+
-| S2M rings | M2S rings | packet buffer 0 | . | pb ((1 <<
pmd->run.log2_ring_size)*(s2m + m2s))-1 |
+| S2M rings | M2S rings | packet buffer 0 | . | pb ((1 <<
pmd->run.log2_ring_size)*(w2i + i2w))-1 |
+-----------+-----------+-----------------+---+---------------------------------------------------+
S2M OR M2S Rings:
+--------+--------+-----------------------+
-| ring 0 | ring 1 | ring num_s2m_rings - 1|
+| ring 0 | ring 1 | ring num_w2i_rings - 1|
+--------+--------+-----------------------+
This is probably a rebase error, looks like it belongs with the memif patch.
<snip>
diff --git a/lib/librte_eal/rte_eal_version.map
b/lib/librte_eal/rte_eal_version.map
index 196eef5afab7..fb8f8a32beaf 100644
--- a/lib/librte_eal/rte_eal_version.map
+++ b/lib/librte_eal/rte_eal_version.map
@@ -79,6 +79,7 @@ DPDK_20.0 {
rte_hexdump;
rte_hypervisor_get;
rte_hypervisor_get_name;
+ rte_init_lcore_id;
Isn't it "rte_get_initial_lcore"?
Also, as i've already mentioned in the response to the cover letter, i
think "main lcore" would be more descriptive than "initial lcore".
--
Thanks,
Anatoly