<snip>

> > 主题: [PATCH v2 2/2] test/ring: rearrange names for ring stress tests
> >
> > Rename test_ring_peek_stress to test_ring_mt_peek_stress to keep same
> > naming conventions for ST and MT test cases.
> >
> > Signed-off-by: Konstantin Ananyev <konstantin.anan...@intel.com>
> > ---
> >  app/test/Makefile                                             | 2 +-
> >  app/test/meson.build                                          | 2 +-
> >  .../{test_ring_peek_stress.c => test_ring_mt_peek_stress.c}   | 2 +-
> >  app/test/test_ring_stress.c                                   | 4 ++--
> >  app/test/test_ring_stress.h                                   | 2 +-
> >  5 files changed, 6 insertions(+), 6 deletions(-)  rename
> > app/test/{test_ring_peek_stress.c => test_ring_mt_peek_stress.c} (94%)
> >
> > diff --git a/app/test/Makefile b/app/test/Makefile index
> > 37bdaf891..e5440774b 100644
> > --- a/app/test/Makefile
> > +++ b/app/test/Makefile
> > @@ -81,7 +81,7 @@ SRCS-y += test_ring.c  SRCS-y +=
> > test_ring_mpmc_stress.c  SRCS-y += test_ring_hts_stress.c  SRCS-y +=
> > test_ring_perf.c -SRCS-y += test_ring_peek_stress.c
> > +SRCS-y += test_ring_mt_peek_stress.c
> >  SRCS-y += test_ring_rts_stress.c
> >  SRCS-y += test_ring_st_peek_stress.c
> >  SRCS-y += test_ring_stress.c
> > diff --git a/app/test/meson.build b/app/test/meson.build index
> > 5cb050958..d8c5b5295 100644
> > --- a/app/test/meson.build
> > +++ b/app/test/meson.build
> > @@ -105,7 +105,7 @@ test_sources = files('commands.c',  'test_ring.c',
> > 'test_ring_mpmc_stress.c',  'test_ring_hts_stress.c',
> > -'test_ring_peek_stress.c',
> > +'test_ring_mt_peek_stress.c',
> So it seems there will be peek API for MT mode, I agree with that.
> However, due to the characteristic of peek API that the thread can change its
> number of planned enqueue elements, after it moves prod_head.
> This may causing confusion for other threads.
> Furthermore, for the implement of peek API for MT or RTS mode, we may
> need to add some restrictions to make it work correctly.
I think this renaming is good enough for the APIs we have currently.
If renaming is required in the future due to new APIs, we could do them when 
needed.

> Thanks.
> >  'test_ring_perf.c',
> >  'test_ring_rts_stress.c',
> >  'test_ring_st_peek_stress.c',
> > diff --git a/app/test/test_ring_peek_stress.c
> > b/app/test/test_ring_mt_peek_stress.c
> > similarity index 94%
> > rename from app/test/test_ring_peek_stress.c rename to
> > app/test/test_ring_mt_peek_stress.c
> > index cfc82d728..4d521422f 100644
> > --- a/app/test/test_ring_peek_stress.c
> > +++ b/app/test/test_ring_mt_peek_stress.c
> > @@ -36,7 +36,7 @@ _st_ring_init(struct rte_ring *r, const char *name,
> > uint32_t num)  RING_F_MP_HTS_ENQ | RING_F_MC_HTS_DEQ);  }
> >
> > -const struct test test_ring_peek_stress = {
> > +const struct test test_ring_mt_peek_stress = {
> >  .name = "MT_PEEK",
> >  .nb_case = RTE_DIM(tests),
> >  .cases = tests,
> > diff --git a/app/test/test_ring_stress.c b/app/test/test_ring_stress.c
> > index
> > 387cfa747..c4f82ea56 100644
> > --- a/app/test/test_ring_stress.c
> > +++ b/app/test/test_ring_stress.c
> > @@ -46,8 +46,8 @@ test_ring_stress(void)  n +=
> > test_ring_hts_stress.nb_case;  k += run_test(&test_ring_hts_stress);
> >
> > -n += test_ring_peek_stress.nb_case;
> > -k += run_test(&test_ring_peek_stress);
> > +n += test_ring_mt_peek_stress.nb_case; k +=
> > +run_test(&test_ring_mt_peek_stress);
> >
> >  n += test_ring_st_peek_stress.nb_case;  k +=
> > run_test(&test_ring_st_peek_stress);
> > diff --git a/app/test/test_ring_stress.h b/app/test/test_ring_stress.h
> > index
> > a9a390341..c85d6fa92 100644
> > --- a/app/test/test_ring_stress.h
> > +++ b/app/test/test_ring_stress.h
> > @@ -35,5 +35,5 @@ struct test {
> >  extern const struct test test_ring_mpmc_stress;  extern const struct
> > test test_ring_rts_stress;  extern const struct test
> > test_ring_hts_stress; -extern const struct test test_ring_peek_stress;
> > +extern const struct test test_ring_mt_peek_stress;
> >  extern const struct test test_ring_st_peek_stress;
> > --
> > 2.17.1
> 

Reply via email to