On 4/24/20 3:12 PM, Liu, Yong wrote: >> IIUC, the only difference with the non-vectorized version is the GSO >> support removed here. >> gso_type being in the same cacheline as flags in virtio_net_hdr, I don't >> think checking the performance gain is worth the added maintainance >> effort due to code duplication. >> >> Please prove I'm wrong, otherwise please move virtio_rx_offload() in a >> header and use it here. Alternative if it really imapcts performance is >> to put all the shared code in a dedicated function that can be re-used >> by both implementations. >> > Maxime, > It won't be much performance difference between non-vectorized and vectorized. > The reason to add special vectorized version is for skipping the handling of > garbage GSO packets. > As all descs have been handled in batch, it is needed to revert when found > garbage packets. > That will introduce complicated logic in vectorized path. What do you mean by garbage packet? Is it really good to just ignore such issues? Thanks, Maxime > Regards, > Marvin >
- [dpdk-dev] [PATCH v9 0/9] add packed ring vectorized path Marvin Liu
- [dpdk-dev] [PATCH v9 2/9] net/virtio: inorder should ... Marvin Liu
- [dpdk-dev] [PATCH v9 1/9] net/virtio: add Rx free thr... Marvin Liu
- [dpdk-dev] [PATCH v9 5/9] net/virtio: add vectorized ... Marvin Liu
- Re: [dpdk-dev] [PATCH v9 5/9] net/virtio: add vec... Maxime Coquelin
- Re: [dpdk-dev] [PATCH v9 5/9] net/virtio: add... Liu, Yong
- Re: [dpdk-dev] [PATCH v9 5/9] net/virtio:... Maxime Coquelin
- Re: [dpdk-dev] [PATCH v9 5/9] net/vi... Liu, Yong
- Re: [dpdk-dev] [PATCH v9 5/9] ne... Liu, Yong
- [dpdk-dev] [PATCH v9 7/9] net/virtio: add vectorized ... Marvin Liu
- Re: [dpdk-dev] [PATCH v9 7/9] net/virtio: add vec... Maxime Coquelin
- Re: [dpdk-dev] [PATCH v9 7/9] net/virtio: add... Liu, Yong
- Re: [dpdk-dev] [PATCH v9 7/9] net/virtio:... Maxime Coquelin
- Re: [dpdk-dev] [PATCH v9 7/9] net/vi... Liu, Yong
- [dpdk-dev] [PATCH v9 4/9] net/virtio-user: add vector... Marvin Liu
- Re: [dpdk-dev] [PATCH v9 4/9] net/virtio-user: ad... Maxime Coquelin
- [dpdk-dev] [PATCH v9 6/9] net/virtio: reuse packed ri... Marvin Liu