On Fri, 31 Jan 2020 22:31:57 +0530 <jer...@marvell.com> wrote: > + > +#define set_err(err, where, fmt, ...) do { \ > + graph_err(fmt, ##__VA_ARGS__); \ > + rte_errno = err; \ > + goto where; \ > +} while (0)
I dislike this macro, it makes static analysis harder and requires the reader to know that the argument is a goto target. And since it is lower case, implies that it is a function. Usually macros are in upper case. It makes the code smaller but a cost of being different which impacts the readability of the code.