On Tue, Oct 29, 2019 at 09:27:22AM +0000, Ferruh Yigit wrote:
> On 10/28/2019 5:18 PM, Stephen Hemminger wrote:
> > On Mon, 26 Aug 2019 18:32:35 +0530
> > Gagandeep Singh <g.si...@nxp.com> wrote:
> > 
> >> --- a/config/common_base
> >> +++ b/config/common_base
> >> @@ -224,6 +224,11 @@ CONFIG_RTE_LIBRTE_CXGBE_DEBUG_TX=n
> >>  CONFIG_RTE_LIBRTE_CXGBE_DEBUG_RX=n
> >>  CONFIG_RTE_LIBRTE_CXGBE_TPUT=y
> >>  
> >> +#
> >> +# Compile burst-oriented NXP PPFE PMD driver
> >> +#
> >> +CONFIG_RTE_LIBRTE_PPFE_PMD=n
> > 
> > This driver should use the common naming convention for Poll Mode Drivers.
> > 
> > s/CONFIG_RTE_LIBRTE_PPFE_PMD/CONFIG_RTE_LIBRTE_PMD_PPFE/
> > 
> 
> Unfortunately we have both as naming convention, and *unintentionally* it 
> become
> virtual ones PMD_XXXX (PMD_RING), physical ones (IXGBE_PMD),
> although this PMD registers itself as virtual, it is a physical PMD and I 
> think
> exiting config option is good (PPFE_PMD).
> 
> We can update config names to be consistent but not sure if it worth it,
> changing name for users/costumers which may break their scripts, automation 
> etc.
> taking into account that it was like this since beginning,
> 
> And now we are planning to switch to meson, these config option won't be used
> directly, so I think we can keep them as they are.

... and the meson default is PMD at the end as for physical PMDs.

Reply via email to