> -----Original Message-----
> From: Jerin Jacob <jerinjac...@gmail.com>
> Sent: Tuesday, October 29, 2019 13:20
> To: Wang, Haiyue <haiyue.w...@intel.com>
> Cc: Thomas Monjalon <tho...@monjalon.net>; Yigit, Ferruh 
> <ferruh.yi...@intel.com>; dpdk-dev
> <dev@dpdk.org>; Ye, Xiaolong <xiaolong...@intel.com>; Kinsella, Ray 
> <ray.kinse...@intel.com>;
> Iremonger, Bernard <bernard.iremon...@intel.com>; Sun, Chenmin 
> <chenmin....@intel.com>; Andrew
> Rybchenko <arybche...@solarflare.com>; Slava Ovsiienko 
> <viachesl...@mellanox.com>; Stephen Hemminger
> <step...@networkplumber.org>; David Marchand <david.march...@redhat.com>; 
> Jerin Jacob
> <jer...@marvell.com>
> Subject: Re: [dpdk-dev] [PATCH v4 1/4] ethdev: add the API for getting burst 
> mode information
> 
> On Tue, Oct 29, 2019 at 10:14 AM Wang, Haiyue <haiyue.w...@intel.com> wrote:
> >
> > > -----Original Message-----
> > > From: Jerin Jacob <jerinjac...@gmail.com>
> > > Sent: Tuesday, October 29, 2019 11:38
> > > To: Wang, Haiyue <haiyue.w...@intel.com>
> > > Cc: Thomas Monjalon <tho...@monjalon.net>; Yigit, Ferruh 
> > > <ferruh.yi...@intel.com>; dpdk-dev
> > > <dev@dpdk.org>; Ye, Xiaolong <xiaolong...@intel.com>; Kinsella, Ray 
> > > <ray.kinse...@intel.com>;
> > > Iremonger, Bernard <bernard.iremon...@intel.com>; Sun, Chenmin 
> > > <chenmin....@intel.com>; Andrew
> > > Rybchenko <arybche...@solarflare.com>; Slava Ovsiienko 
> > > <viachesl...@mellanox.com>; Stephen
> Hemminger
> > > <step...@networkplumber.org>; David Marchand <david.march...@redhat.com>; 
> > > Jerin Jacob
> > > <jer...@marvell.com>
> > > Subject: Re: [dpdk-dev] [PATCH v4 1/4] ethdev: add the API for getting 
> > > burst mode information
> > >
> > > > > > > struct rte_eth_burst_mode {
> > > > > > >         uint64_t options;
> > > > > > >         char dev_specific[128]; /* PMD has specific burst mode 
> > > > > > > information */
> > > > > > > };
> > > > > >
> > > > > > I really don't see how we can have generic flags.
> > > > > > The flags which are proposed are just matching
> > > > > > the functions implemented in Intel PMDs.
> > > > > > And this is a complicate solution.
> > > > > > Why not just returning a name for the selected Rx/Tx mode?
> > > > >
> > > > > +1 only for the name
> > > > >
> > > > > Let me clarify my earlier proposal:
> > > > >
> > > > > 1) The public ethdev API should return only "string" i.e the flags
> > > > > SHOULD NOT be exposed as ethdev API
> > > > > i.e
> > > > > int rte_eth_tx_burst_mode_name(uint16_t port_id, uint16_t queue_id, 
> > > > > char *name);
> > > > >
> > > > > 2) The PMD interface  to the common code can be following
> > > > >
> > > > >  struct eth_pmd_burst_mode {
> > > > >         uint64_t options;
> > > > >          char name[128]; /* PMD specific burst mode information */
> > > > > };
> > > > >
> > > > > typedef int (*eth_burst_mode_get_t)(struct rte_eth_dev *dev,
> > > > >         uint16_t queue_id, struct eth_burst_mode *mode)
> > > > >
> > > > > 3) The implementation of rte_eth_tx_burst_mode_name() shall do optons
> > > > > flag to string converion(again internal to common code implemetation)
> > > > > and concatenate with eth_pmd_burst_mode::name
> > > > >
> > > > > This would help to reuse some of the flags to name conversion logic
> > > > > across all PMDs.
> > > > > And PMD are free to return  eth_pmd_burst_mode::options as zero in
> > > > > that case final
> > > > > string only be eth_pmd_burst_mode::name.
> > > > >
> > > >
> > > > In fact, 'rte_eth_burst_mode_option_name' for single option, not
> > > > for struct eth_pmd_burst_mode::option[s]. Need loop to display them.
> > >
> > > I see two issues with the flag approach in public API(Internally for
> > > common code it fine to avoid code duplication)
> > >
> > > 1) We can not standardize all flags when it comes to HW specific
> > > details. We should NOT pollute public API with HW specific details.
> >
> > Currently, no detail to HW NIC specific.
> 
> Yes. What if I want to add a "String" they represent a specific mode of PMD,
> so that I know what mode PMD really runs.
> It is not worth adding a flag for that in public API for HW specific notion.
> That's the problem.
> 
> >
> > > 2) There is a danger if application starts taking any action based on
> > > flags. It should be only for display purpose so in that case public
> > > API should be the string to avoid misuse of the API(eventually the app
> > > will fail on some PMD
> > > if it takes any action based on the flag)
> >
> > These flags are *read only* for information. Can't image how to hack DPDK. 
> > ;-)
> 
> To clarify:
> If we expose flag say RTE_ETH_BURST_SIMPLE then the application can take
> some action based on
> if (flag == RTE_ETH_BURST_SIMPLE)
>     do_some_thing();
> 
> If the purpose is ONLY for "display" as info then exposing as the string will
> enable to NOT standardize i.e application can never check based on
> the string name(as it is not standardized) hence no danger.
> 
> So what is the purpose of this API? Just display or are you expecting
> the application can do any action based on this?

Oh, I see. Mainly for showing which burst rx/tx module running:

https://docs.fd.io/vpp/18.11/d7/d1d/plugins_2dpdk_2device_2format_8c_source.html

s = format (s, "%Utx burst function: %s\n",
  579                   format_white_space, indent + 2,
  580                   ptr2sname (rte_eth_devices[xd->port_id].tx_pkt_burst));
  581       s = format (s, "%Urx burst function: %s\n",
  582                   format_white_space, indent + 2,
  583                   ptr2sname (rte_eth_devices[xd->port_id].rx_pkt_burst));

https://docs.fd.io/vpp/18.11/d7/d1d/plugins_2dpdk_2device_2format_8c_source.html

488 static const char *
  489 ptr2sname (void *p)
  490 {
  491   Dl_info info = { 0 };
  492 
  493   if (dladdr (p, &info) == 0)
  494     return 0;
  495 
  496   return info.dli_sname;
  497 }

    tx burst function: ixgbe_xmit_pkts
    rx burst function: ixgbe_recv_pkts

If the PMD's rx/tx is *static* function, 'ptr2name' returns 'nil'.

Reply via email to