On Thu, 10 Oct 2019 08:26:21 +0000 Morten Brørup <m...@smartsharesystems.com> wrote:
> Add function for freeing a bulk of mbufs. > > v6: > * Remove __rte_always_inline from static function. > The compiler will inline anyway. > v5: > * Rename variables from "free" to "pending" for improved readability. > * Add prefix __ to rte_pktmbuf_free_seg_via_array(). > * Add array size parameter to __rte_pktmbuf_free_seg_via_array(). > The compiler will optimize the parameter away anyway. > * Add description to __rte_pktmbuf_free_seg_via_array(). > * Minor description updates. > v4: > * Mark as experimental by adding __rte_experimental. > * Add function to experimental section of map file. > * Fix source code formatting regarding pointer to pointer. > * Squash multiple modifications into one. > v3: > * Bugfix: Handle pakets with multiple segments. > * Add inline helper function, mainly for readability. > * Fix source code formatting regarding indentation. > v2: > * Function is not inline. > * Optimize to free multible mbufs belonging to the same mempool in > bulk. Inspired by ixgbe_tx_free_bufs(), but allowing NULL pointers > in the array, just like rte_pktmbuf_free() can take a NULL pointer. > * Use unsigned int instead of unsigned. Passes checkpatch, but > mismatches the original coding style of the modified files. > * Fix a typo in the description headline: mempools is plural. > > Signed-off-by: Morten Brørup <m...@smartsharesystems.com> These two could be squashed together when merged Acked-by: Stephen Hemminger <step...@networkplumber.org>