On Thu, Aug 22, 2019 at 11:43 AM Gavin Hu <gavin...@arm.com> wrote: > > The rte_wait_until_equalxx APIs abstract the functionality of 'polling > for a memory location to become equal to a given value'. > > Signed-off-by: Gavin Hu <gavin...@arm.com> > Reviewed-by: Ruifeng Wang <ruifeng.w...@arm.com> > Reviewed-by: Steve Capper <steve.cap...@arm.com> > Reviewed-by: Ola Liljedahl <ola.liljed...@arm.com> > Reviewed-by: Honnappa Nagarahalli <honnappa.nagaraha...@arm.com> > Reviewed-by: Phil Yang <phil.y...@arm.com> > Acked-by: Pavan Nikhilesh <pbhagavat...@marvell.com> > --- > .../common/include/arch/arm/rte_pause_64.h | 30 > ++++++++++++++++++++++ > lib/librte_eal/common/include/generic/rte_pause.h | 26 ++++++++++++++++++- > 2 files changed, 55 insertions(+), 1 deletion(-) > > diff --git a/lib/librte_eal/common/include/arch/arm/rte_pause_64.h > b/lib/librte_eal/common/include/arch/arm/rte_pause_64.h > index 93895d3..dabde17 100644 > --- a/lib/librte_eal/common/include/arch/arm/rte_pause_64.h > +++ b/lib/librte_eal/common/include/arch/arm/rte_pause_64.h > @@ -1,5 +1,6 @@ > /* SPDX-License-Identifier: BSD-3-Clause > * Copyright(c) 2017 Cavium, Inc > + * Copyright(c) 2019 Arm Limited > */ > > #ifndef _RTE_PAUSE_ARM64_H_ > @@ -17,6 +18,35 @@ static inline void rte_pause(void) > asm volatile("yield" ::: "memory"); > } > > +#ifdef RTE_ARM_USE_WFE > +#define __WAIT_UNTIL_EQUAL(name, asm_op, wide, type) \ > +static __rte_always_inline void \ > +rte_wait_until_equal_##name(volatile type * addr, type expected) \ > +{ \ > + type tmp; \ > + asm volatile( \ > + #asm_op " %" #wide "[tmp], %[addr]\n" \ > + "cmp %" #wide "[tmp], %" #wide "[expected]\n" \ > + "b.eq 2f\n" \ > + "sevl\n" \ > + "1: wfe\n" \ > + #asm_op " %" #wide "[tmp], %[addr]\n" \ > + "cmp %" #wide "[tmp], %" #wide "[expected]\n" \ > + "bne 1b\n" \ > + "2:\n" \ > + : [tmp] "=&r" (tmp) \ > + : [addr] "Q"(*addr), [expected] "r"(expected) \ > + : "cc", "memory"); \ > +} > > +/* Wait for *addr to be updated with expected value */ > +__WAIT_UNTIL_EQUAL(relaxed_16, ldxrh, w, uint16_t) > +__WAIT_UNTIL_EQUAL(acquire_16, ldaxrh, w, uint16_t) > +__WAIT_UNTIL_EQUAL(relaxed_32, ldxr, w, uint32_t) > +__WAIT_UNTIL_EQUAL(acquire_32, ldaxr, w, uint32_t) > +__WAIT_UNTIL_EQUAL(relaxed_64, ldxr, x, uint64_t) > +__WAIT_UNTIL_EQUAL(acquire_64, ldaxr, x, uint64_t) >
This scheme doesn't allow to write Doxygen comments for the API Please change to some scheme where you can Doxygen comments for each API without code duplication. Something like /** * Doxygen comment */ rte_wait_until_equal_relaxed_16(..) { __WAIT_UNTIL_EQUAL(..) }