Right now inclusion of rte_mbuf.h header can cause inclusion of some arch/os specific headers. That prevents it to be included directly by some non-DPDK (but related) entities: KNI, BPF programs, etc. To overcome that problem usually a separate definitions of rte_mbuf structure is created within these entities. That aproach has a lot of drawbacks: code duplication, error prone, etc. This series moves rte_mbuf structure definition (and some related macros) into a separate file that can be included by both rte_mbuf.h and other non-DPDK entities.
Note that these moves shouldn't introduce any change for current DPDK code. Konstantin Ananyev (3): eal: move CACHE and IOVA related definitions mbuf: move mbuf definition into a separate file examples/bpf: remove duplicate mbuf definition examples/bpf/t2.c | 5 +- examples/bpf/t3.c | 3 +- lib/librte_eal/common/include/rte_common.h | 44 ++ lib/librte_eal/common/include/rte_memory.h | 38 - lib/librte_mbuf/Makefile | 5 +- lib/librte_mbuf/meson.build | 3 +- lib/librte_mbuf/rte_mbuf.h | 738 +----------------- .../mbuf.h => lib/librte_mbuf/rte_mbuf_core.h | 556 ++++++++----- 8 files changed, 428 insertions(+), 964 deletions(-) rename examples/bpf/mbuf.h => lib/librte_mbuf/rte_mbuf_core.h (51%) -- 2.17.1