From: Pavan Nikhilesh <pbhagavat...@marvell.com> Add new offload flags ``DEV_RX_OFFLOAD_PTYPE``, ``DEV_RX_OFFLOAD_RSS`` and ``DEV_RX_OFFLOAD_FLOW_MARK``.
Signed-off-by: Pavan Nikhilesh <pbhagavat...@marvell.com> Acked-by: Andrew Rybchenko <arybche...@solarflare.com> --- v2: Reword for clarity. doc/guides/rel_notes/deprecation.rst | 13 +++++++++++++ 1 file changed, 13 insertions(+) diff --git a/doc/guides/rel_notes/deprecation.rst b/doc/guides/rel_notes/deprecation.rst index 37b8592b6..79e50a272 100644 --- a/doc/guides/rel_notes/deprecation.rst +++ b/doc/guides/rel_notes/deprecation.rst @@ -78,3 +78,16 @@ Deprecation Notices to set new power environment if power environment was already initialized. In this case the function will return -1 unless the environment is unset first (using ``rte_power_unset_env``). Other function usage scenarios will not change. + +* ethdev: New offload flags ``DEV_RX_OFFLOAD_PTYPE``, ``DEV_RX_OFFLOAD_RSS`` + and ``DEV_RX_OFFLOAD_FLOW_MARK`` will be added in 19.11. + This will allow application to enable or disable PMDs from updating + ``rte_mbuf`` fields ``rte_mbuf::packet_type``, ``rte_mbuf::hash::rss`` and + ``rte_mbuf::hash::fdir`` respectively. + This scheme will allow PMDs to avoid writes to ``rte_mbuf`` fields on Rx and + thereby improve Rx performance if application wishes do so. + In 19.11 PMDs will still update the fields even when the offloads are not + enabled. + The exact semantics of the flags will be worked out later either by making + them negative offloads to avoid application change or positive offload to + align with existing offload flag semantics. -- 2.17.1