On Fri, 11 Dec 2015 11:28:48 +0200 Panu Matilainen <pmatilai at redhat.com> wrote:
> On 12/11/2015 01:27 AM, Stephen Hemminger wrote: > > Plan to change to <net/ethernet.h> version of struct ether_addr in > > DPDK 2.3. The change in DPDK source is trivial but it will impact > > source compatablilty therefore notification is necessary. > > > > Signed-off-by: Stephen Hemminger <stephen at networkplumber.org> > > --- > > doc/guides/rel_notes/deprecation.rst | 5 +++++ > > 1 file changed, 5 insertions(+) > > > > diff --git a/doc/guides/rel_notes/deprecation.rst > > b/doc/guides/rel_notes/deprecation.rst > > index 1c7ab01..8ecb990 100644 > > --- a/doc/guides/rel_notes/deprecation.rst > > +++ b/doc/guides/rel_notes/deprecation.rst > > @@ -19,3 +19,8 @@ Deprecation Notices > > and table action handlers will be updated: > > the pipeline parameter will be added, the packets mask parameter will be > > either removed (for input port action handler) or made input-only. > > + > > +* librte_ether: The structure ether_addr in DPDK will be replaced > > + by using the standard header file <net/ethernet.h>. The structure > > + size will be the same (no ABI impact), but the structure field name > > + will change from addr_bytes[] to ether_addr_octet[]. > > > > I hope there is some other reason/benefit besides getting rid of a > three-line custom struct definition. It may be a trivial > s/addr_bytes/ether_addr_octet/ change but it touches a lot of places all > over the DPDK codebase alone, and for 3rd party developers such (at > least seemingly) gratuitous renames are really irritating. > > - Panu - > It allows dropping dependency on cmdline in several places in code (by using ether_ntoa instead). The problem was a day 0 choice in DPDK to define their own struct's everywhere.