Hello Chas, On Fri, Apr 12, 2019 at 4:02 PM Chas Williams <3ch...@gmail.com> wrote:
> I should have some time this weekend to run these patches through our > regression system. > Did you manage to run this series through your tests system ? > On 4/10/19 8:53 AM, David Marchand wrote: > > @@ -357,10 +318,16 @@ > > hdr = rte_pktmbuf_mtod(bufs[j], struct ether_hdr > *); > > subtype = ((struct slow_protocol_frame > *)hdr)->slow_protocol.subtype; > > > > - /* Remove packet from array if it is slow packet > or slave is not > > - * in collecting state or bonding interface is not > in promiscuous > > - * mode and packet address does not match. */ > > - if (unlikely(is_lacp_packets(hdr->ether_type, > subtype, bufs[j]) || > > + /* Remove packet from array if: > > + * - it is slow packet but no dedicated rxq is > present, > > + * - slave is not in collecting state, > > + * - bonding interface is not in promiscuous mode > and > > + * packet is not multicast and address does not > match, > > + */ > > + if (unlikely( > > The coding style checker doesn't like this: > > CHECK:OPEN_ENDED_LINE: Lines should not end with a '(' > Yes, I had seen this warning, just found it easier to read this way. > > + (!dedicated_rxq && > > + is_lacp_packets(hdr->ether_type, subtype, > > + bufs[j])) || > > !collecting || > > (!promisc && > > !is_multicast_ether_addr(&hdr->d_addr) && > > -- David Marchand