Hi Konstantin, I do not see ipsec lib in Shared Library Versions in release notes. Could you also send that change.
Thanks, Akhil On 3/26/2019 9:13 PM, Konstantin Ananyev wrote: > v3 -> v2 > Address comments: > - make rte_mbuf_tx_offload() always inline > - rename OL[2,3]_LEN to OUTL[2,3]_LEN for better naming > Add 'unused' parameter into rte_mbuf_tx_offload() for consistency > Some code de-duplication > > v1 -> v2 > Add patch to improve a bit esp inbound pkt_process code > > The first patch in this series introduces new function to > set raw value for rte_mbuf tx_offload. > Remaining ones are cleanups and small performance improvements > (on IA ~3-6% depending on the test-case) for ipsec library. > > Konstantin Ananyev (8): > mbuf: new function to generate raw Tx offload value > ipsec: add Tx offload template into SA > ipsec: change the order in filling crypto op > ipsec: change the way unprocessed mbufs are accounted > ipsec: move inbound and outbound code into different files > ipsec: reorder packet check for esp inbound > ipsec: reorder packet process for esp inbound > ipsec: de-duplicate crypto op prepare code-path > > lib/librte_ipsec/Makefile | 2 + > lib/librte_ipsec/crypto.h | 17 + > lib/librte_ipsec/esp_inb.c | 547 +++++++++++++++++ > lib/librte_ipsec/esp_outb.c | 580 ++++++++++++++++++ > lib/librte_ipsec/ipsec_sqn.h | 34 -- > lib/librte_ipsec/meson.build | 2 +- > lib/librte_ipsec/misc.h | 41 ++ > lib/librte_ipsec/sa.c | 1072 ++-------------------------------- > lib/librte_ipsec/sa.h | 45 ++ > lib/librte_mbuf/rte_mbuf.h | 79 ++- > 10 files changed, 1364 insertions(+), 1055 deletions(-) > create mode 100644 lib/librte_ipsec/esp_inb.c > create mode 100644 lib/librte_ipsec/esp_outb.c > create mode 100644 lib/librte_ipsec/misc.h >