On 01/17, Andy Pei wrote: >fix a typo and delete code of unused function > >Cc: andy....@intel.com >Cc: rosen...@intel.com >Cc: tianfei.zh...@intel.com > >Signed-off-by: Andy Pei <andy....@intel.com> >--- > drivers/raw/ifpga_rawdev/base/opae_hw_api.c | 24 +----------------------- > 1 file changed, 1 insertion(+), 23 deletions(-) > >diff --git a/drivers/raw/ifpga_rawdev/base/opae_hw_api.c >b/drivers/raw/ifpga_rawdev/base/opae_hw_api.c >index 50f6438..ea42757 100644 >--- a/drivers/raw/ifpga_rawdev/base/opae_hw_api.c >+++ b/drivers/raw/ifpga_rawdev/base/opae_hw_api.c >@@ -304,7 +304,7 @@ static struct opae_adapter_ops *match_ops(struct >opae_adapter *adapter) > > /** > * opae_adapter_init - init opae_adapter data structure >- * @adpdate: pointer of opae_adater data structure >+ * @adapter: pointer of opae_adater data structure
Seems there is another typo here, s/opae_adater/opae_adapter/ Thanks, Xiaolong > * @name: adapter name. > * @data: private data of this adapter. > * >@@ -325,28 +325,6 @@ int opae_adapter_init(struct opae_adapter *adapter, > } > > /** >- * opae_adapter_alloc - alloc opae_adapter data structure >- * @name: adapter name. >- * @data: private data of this adapter. >- * >- * Return: opae_adapter on success, otherwise NULL. >- */ >- /**This function will no longer be called. >-struct opae_adapter *opae_adapter_alloc(const char *name, void *data) >-{ >- struct opae_adapter *adapter = opae_zmalloc(sizeof(*adapter)); >- >- if (!adapter) >- return NULL; >- >- if (opae_adapter_init(adapter, name, data)) >- return NULL; >- >- return adapter; >-} >-**/ >- >-/** > * opae_adapter_enumerate - enumerate this adapter > * @adapter: adapter to enumerate. > * >-- >1.8.3.1 >