> 
> Rename rte_bsf64 to rte_bsf64_safe (this is a "safe" version in
> that it prevents undefined behavior by checking if incoming
> parameter is zero) and move it to common header.

Probably a stupid one: why to rename?
Why just not fix rte_bsf64 to make it work with zero value,
and keep the same function name?
Konstantin

> 
> Signed-off-by: Anatoly Burakov <anatoly.bura...@intel.com>
> Acked-by: Cristian Dumitrescu <cristian.dumitre...@intel.com>
> Acked-by: Jasvinder Singh <jasvinder.si...@intel.com>
> ---
>  doc/guides/rel_notes/deprecation.rst       |  5 +++++
>  lib/librte_eal/common/include/rte_bitmap.h | 14 ++++---------
>  lib/librte_eal/common/include/rte_common.h | 23 ++++++++++++++++++++++
>  3 files changed, 32 insertions(+), 10 deletions(-)
> 
> diff --git a/doc/guides/rel_notes/deprecation.rst 
> b/doc/guides/rel_notes/deprecation.rst
> index 34b28234c..553e99171 100644
> --- a/doc/guides/rel_notes/deprecation.rst
> +++ b/doc/guides/rel_notes/deprecation.rst
> @@ -22,6 +22,11 @@ Deprecation Notices
> 
>      + ``rte_eal_devargs_type_count``
> 
> +* eal: function ``rte_bsf64`` in ``rte_bitmap.h`` has been renamed to
> +  ``rte_bsf64_safe`` and moved to ``rte_common.h``. A new ``rte_bsf64`` 
> function
> +  will be added in the next release in ``rte_common.h`` that follows 
> convention
> +  set by existing ``rte_bsf32`` function.
> +
>  * pci: Several exposed functions are misnamed.
>    The following functions are deprecated starting from v17.11 and are 
> replaced:
> 
> diff --git a/lib/librte_eal/common/include/rte_bitmap.h 
> b/lib/librte_eal/common/include/rte_bitmap.h
> index d2ed6204c..77727c828 100644
> --- a/lib/librte_eal/common/include/rte_bitmap.h
> +++ b/lib/librte_eal/common/include/rte_bitmap.h
> @@ -93,14 +93,10 @@ __rte_bitmap_index2_set(struct rte_bitmap *bmp)
>       bmp->index2 = (((bmp->index1 << RTE_BITMAP_SLAB_BIT_SIZE_LOG2) + 
> bmp->offset1) << RTE_BITMAP_CL_SLAB_SIZE_LOG2);
>  }
> 
> -static inline int
> +static inline int __rte_deprecated
>  rte_bsf64(uint64_t slab, uint32_t *pos)
>  {
> -     if (slab == 0)
> -             return 0;
> -
> -     *pos = __builtin_ctzll(slab);
> -     return 1;
> +     return rte_bsf64_safe(slab, pos);
>  }
> 
>  static inline uint32_t
> @@ -408,9 +404,8 @@ __rte_bitmap_scan_search(struct rte_bitmap *bmp)
>       value1 = bmp->array1[bmp->index1];
>       value1 &= __rte_bitmap_mask1_get(bmp);
> 
> -     if (rte_bsf64(value1, &bmp->offset1)) {
> +     if (rte_bsf64_safe(value1, &bmp->offset1))
>               return 1;
> -     }
> 
>       __rte_bitmap_index1_inc(bmp);
>       bmp->offset1 = 0;
> @@ -419,9 +414,8 @@ __rte_bitmap_scan_search(struct rte_bitmap *bmp)
>       for (i = 0; i < bmp->array1_size; i ++, __rte_bitmap_index1_inc(bmp)) {
>               value1 = bmp->array1[bmp->index1];
> 
> -             if (rte_bsf64(value1, &bmp->offset1)) {
> +             if (rte_bsf64_safe(value1, &bmp->offset1))
>                       return 1;
> -             }
>       }
> 
>       return 0;
> diff --git a/lib/librte_eal/common/include/rte_common.h 
> b/lib/librte_eal/common/include/rte_common.h
> index 87f0f6302..d115b175c 100644
> --- a/lib/librte_eal/common/include/rte_common.h
> +++ b/lib/librte_eal/common/include/rte_common.h
> @@ -491,6 +491,29 @@ rte_fls_u32(uint32_t x)
>       return (x == 0) ? 0 : 32 - __builtin_clz(x);
>  }
> 
> +/**
> + * Searches the input parameter for the least significant set bit
> + * (starting from zero). Safe version (checks for input parameter being 
> zero).
> + *
> + * @warning ``pos`` must be a valid pointer. It is not checked!
> + *
> + * @param v
> + *     The input parameter.
> + * @param pos
> + *     If ``v`` was not 0, this value will contain position of least 
> significant
> + *     bit within the input parameter.
> + * @return
> + *     Returns 0 if ``v`` was 0, otherwise returns 1.
> + */
> +static inline int
> +rte_bsf64_safe(uint64_t v, uint32_t *pos)
> +{
> +     if (v == 0)
> +             return 0;
> +
> +     *pos = __builtin_ctzll(v);
> +     return 1;
> +}
> 
>  #ifndef offsetof
>  /** Return the offset of a field in a structure. */
> --
> 2.17.1

Reply via email to