23/10/2018 12:01, Iremonger, Bernard: > From: Thomas Monjalon [mailto:tho...@monjalon.net] > > The command "port detach" is removing the EAL rte_device of the ethdev > > port specified as parameter. > > > > After detaching, the pointer, which maps a port to its device, is resetted. > > This > > Typo: "resetted" should be "reset" > > > way, it is possible to check whether a port is still associated to a (not > > removed) device. > > > > Signed-off-by: Thomas Monjalon <tho...@monjalon.net> > > --- > > app/test-pmd/testpmd.c | 24 +++++++++++++++++++++--- > > 1 file changed, 21 insertions(+), 3 deletions(-) > > > > diff --git a/app/test-pmd/testpmd.c b/app/test-pmd/testpmd.c index > > 14647fa19..d5998fddc 100644 > > --- a/app/test-pmd/testpmd.c > > +++ b/app/test-pmd/testpmd.c > > @@ -2353,8 +2353,17 @@ setup_attached_port(portid_t pi) void > > detach_port(portid_t port_id) { > > + struct rte_device *dev; > > + portid_t sibling; > > + > > printf("Removing a device...\n"); > > The functionality of the detach_port() function has changed now to > removing a device, should the function name be changed to reflect > the new functionality.
No it doesn't change, it has always removed the rte_device of the port. But the naming is a bit strange, I agree. I just changed the log to make it a bit clearer. > How about detach_device() instead of detach detach_port(). The strange thing with testpmd is that every commands take a port id. The rte_device is hidden in testpmd. So the detach command is detaching the underlying device of the port, and all its sibling ports of course. What about detach_device_of_port() ? [...] > > - if (rte_dev_remove(rte_eth_devices[port_id].device) != 0) { > > + if (rte_dev_remove(dev) != 0) { > > TESTPMD_LOG(ERR, "Failed to detach port %u\n", port_id); > > Should the log message be ( ERR "Failed to detach device %s\n", dev->name) ? Yes! [...] > > - printf("Port %u is detached. Now total ports is %d\n", > > - port_id, nb_ports); > > How about printf("Device %s is detached, Now total ports is %d\n" > dev->name, nb_ports); The issue is that we cannot get the device name after detach. I can reword it differently: Device of port %u is detached, Now total ports is %d