On 17-Sep-18 2:46 PM, Darek Stojaczyk wrote:
From: Dariusz Stojaczyk <dariuszx.stojac...@intel.com>
Factor out duplicated code.
Signed-off-by: Dariusz Stojaczyk <dariuszx.stojac...@intel.com>
---
<snip>
+
+int
+rte_vfio_get_group_fd(int iommu_group_num)
+{
+ struct vfio_config *vfio_cfg;
+
+ /* get the vfio_config it belongs to */
+ vfio_cfg = get_vfio_cfg_by_group_num(iommu_group_num);
+ vfio_cfg = vfio_cfg ? vfio_cfg : default_vfio_cfg;
I tend to prefer being explicit rather than implicit (i.e. 'vfio_cfg ==
NULL' instead of 'vfio_cfg').
Otherwise,
Acked-by: Anatoly Burakov <anatoly.bura...@intel.com>
--
Thanks,
Anatoly