Hi Michel,
        I applied your patch and tweaked the code to run few performance tests 
on Arm (Cortex-A72, 1.3GHz) and x86 (Intel Xeon CPU E5-2660 v4 @ 2.00GHz). The 
perf code looks as follows:

        count_b = rte_rdtsc_precise();
        int k = 0;
        rte_hash_iterator_init(tbl_rw_test_param.h, &state);

        while (rte_hash_iterate(&state, &next_key, &next_data) >= 0) {
                /* Search for the key in the list of keys added .*/
                i = *(const uint32_t *)next_key;
                tbl_rw_test_param.found[i]++;
                k++;
        }

        count_a = rte_rdtsc_precise() - count_b;
        printf("*****Cycles2 per iterate call: %lu\n", count_a/k);

Further, I changed the rte_hash_iterate as follows and ran the same test.
int32_t rte_hash_iterate(const struct rte_hash *h, struct 
rte_hash_iterator_state *state, const void **key, void **data)

Finally, I used memset in the place of rte_hash_iterator_init with the required 
changes to rte_hash_iterate.

All these tests show little variation in 'cycles per iterate call' for both 
architectures.


-----Original Message-----
From: Michel Machado <mic...@digirati.com.br> 
Sent: Thursday, September 6, 2018 9:29 AM
To: Honnappa Nagarahalli <honnappa.nagaraha...@arm.com>; Qiaobin Fu 
<qiaob...@bu.edu>; bruce.richard...@intel.com; pablo.de.lara.gua...@intel.com
Cc: dev@dpdk.org; douce...@bu.edu; keith.wi...@intel.com; 
sameh.gobr...@intel.com; charlie....@intel.com; step...@networkplumber.org; nd 
<n...@arm.com>; yipeng1.w...@intel.com
Subject: Re: [PATCH v3] hash table: add an iterator over conflicting entries

On 09/05/2018 06:13 PM, Honnappa Nagarahalli wrote:
>> +    uint32_t              next;
>> +    uint32_t              total_entries;
>> +};
>> This structure can be moved to rte_cuckoo_hash.h file.
> 
>      What's the purpose of moving this struct to a header file since it's 
> only used in the C file rte_cuckoo_hash.c?
> 
> This is to maintain consistency. For ex: 'struct queue_node', which is 
> an internal structure, is kept in rte_cuckoo_hash.h

    Okay. We'll move it there.

>> +int32_t
>> +rte_hash_iterator_init(const struct rte_hash *h,
>> +    struct rte_hash_iterator_state *state) {
>> +    struct rte_hash_iterator_istate *__state;
>> '__state' can be replaced by 's'.
>>
>> +
>> +    RETURN_IF_TRUE(((h == NULL) || (state == NULL)), -EINVAL);
>> +
>> +    __state = (struct rte_hash_iterator_istate *)state;
>> +    __state->h = h;
>> +    __state->next = 0;
>> +    __state->total_entries = h->num_buckets * RTE_HASH_BUCKET_ENTRIES;
>> +
>> +    return 0;
>> +}
>> IMO, creating this API can be avoided if the initialization is handled in 
>> 'rte_hash_iterate' function. The cost of doing this is very trivial (one 
>> extra 'if' statement) in 'rte_hash_iterate' function. It will help keep the 
>> number of APIs to minimal.
> 
>      Applications would have to initialize struct rte_hash_iterator_state 
> *state before calling rte_hash_iterate() anyway. Why not initializing the 
> fields of a state only once?
> 
> My concern is about creating another API for every iterator API. You have a 
> valid point on saving cycles as this API applies for data plane. Have you 
> done any performance benchmarking with and without this API? May be we can 
> guide our decision based on that.

    It's not just about creating one init function for each iterator because an 
iterator may have a couple of init functions. For example, someone may 
eventually find useful to add another init function for the conflicting-entry 
iterator that we are advocating in this patch. A possibility would be for this 
new init function to use the key of the new entry instead of its signature to 
initialize the state. Similar to what is already done in rte_hash_lookup*() 
functions. In spite of possibly having multiple init functions, there will be a 
single iterator function.

    About the performance benchmarking, the current API only requites 
applications to initialize a single 32-bit integer. But with the adoption of a 
struct for the state, the initialization will grow to 64 bytes.

As my tests showed, I do not see any impact of this.

>>    int32_t
>> -rte_hash_iterate(const struct rte_hash *h, const void **key, void 
>> **data, uint32_t *next)
>> +rte_hash_iterate(
>> +    struct rte_hash_iterator_state *state, const void **key, void
>> +**data)
>>
>> IMO, as suggested above, do not store 'struct rte_hash *h' in 'struct 
>> rte_hash_iterator_state'. Instead, change the API definition as follows:
>> rte_hash_iterate(const struct rte_hash *h, const void **key, void 
>> **data, struct rte_hash_iterator_state *state)
>>
>> This will help keep the API signature consistent with existing APIs.
>>
>> This is an ABI change. Please take a look at 
>> https://doc.dpdk.org/guides/contributing/versioning.html.
> 
>      The ABI will change in a way or another, so why not going for a single 
> state instead of requiring parameters that are already needed for the 
> initialization of the state?
> 
> Are there any cost savings we can achieve by keeping the 'h' in the iterator 
> state?

    There's a tiny cost saving: avoiding to push that parameter in the 
execution stack every time the iterator will get another entry. However, the 
reason I find more important is to make impossible to introduce a bug in the 
code. Consider a function that is dealing with two hash tables and two 
iterators. Without asking for the hash table to make progress in an iterator, 
it's impossible to mix up hash tables and iterator states.

IMO, similar arguments can be applied for other APIs too. It is more difficult 
to use the APIs if they are not consistent. I also do not see the benefit of 
the savings in my tests. 

    There's even the possibility that an iterator doesn't need the hash table 
after its initialization. This would be an *unlikely* case, but consider an 
iterator that only returns a couple of entries. It could cache those entries 
during initialization.

>>      /* Calculate bucket and index of current iterator */
>> -    bucket_idx = *next / RTE_HASH_BUCKET_ENTRIES;
>> -    idx = *next % RTE_HASH_BUCKET_ENTRIES;
>> +    bucket_idx = __state->next / RTE_HASH_BUCKET_ENTRIES;
>> +    idx = __state->next % RTE_HASH_BUCKET_ENTRIES;
>>    
>>      /* If current position is empty, go to the next one */
>> -    while (h->buckets[bucket_idx].key_idx[idx] == EMPTY_SLOT) {
>> -            (*next)++;
>> +    while (__state->h->buckets[bucket_idx].key_idx[idx] == EMPTY_SLOT) {
>> +            __state->next++;
>>              /* End of table */
>> -            if (*next == total_entries)
>> +            if (__state->next == __state->total_entries)
>>                      return -ENOENT;
>> -            bucket_idx = *next / RTE_HASH_BUCKET_ENTRIES;
>> -            idx = *next % RTE_HASH_BUCKET_ENTRIES;
>> +            bucket_idx = __state->next / RTE_HASH_BUCKET_ENTRIES;
>> +            idx = __state->next % RTE_HASH_BUCKET_ENTRIES;
>>      }
>> -    __hash_rw_reader_lock(h);
>> +    __hash_rw_reader_lock(__state->h);
>>      /* Get position of entry in key table */
>> -    position = h->buckets[bucket_idx].key_idx[idx];
>> -    next_key = (struct rte_hash_key *) ((char *)h->key_store +
>> -                            position * h->key_entry_size);
>> +    position = __state->h->buckets[bucket_idx].key_idx[idx];
>> +    next_key = (struct rte_hash_key *) ((char *)__state->h->key_store +
>> +                            position * __state->h->key_entry_size);
>>      /* Return key and data */
>>      *key = next_key->key;
>>      *data = next_key->pdata;
>>    
>> -    __hash_rw_reader_unlock(h);
>> +    __hash_rw_reader_unlock(__state->h);
>>    
>>      /* Increment iterator */
>> -    (*next)++;
>> +    __state->next++;
>> This comment is not related to this change, it is better to place this 
>> inside the lock.
> 
>      Even though __state->next does not depend on the lock?
> 
> It depends on if this API needs to be multi-thread safe. Interestingly, the 
> documentation does not say it is multi-thread safe. If it has to be 
> multi-thread safe, then the state also needs to be protected. For ex: what 
> happens if the user uses a global variable for the state?

    If an application needs to share an iterator state between threads, it has 
to have a synchronization mechanism for that as it would for any other shared 
variable. The lock above is allowing applications to share a hash table between 
threads, it has no semantic over anything else.

Agree, the lock is for protecting the hash table, not the iterator state.

>> diff --git a/lib/librte_hash/rte_hash.h b/lib/librte_hash/rte_hash.h 
>> index 9e7d9315f..fdb01023e 100644
>> --- a/lib/librte_hash/rte_hash.h
>> +++ b/lib/librte_hash/rte_hash.h
>> @@ -14,6 +14,8 @@
>>    #include <stdint.h>
>>    #include <stddef.h>
>>    
>> +#include <rte_compat.h>
>> +
>>    #ifdef __cplusplus
>>    extern "C" {
>>    #endif
>> @@ -64,6 +66,16 @@ struct rte_hash_parameters {
>>    /** @internal A hash table structure. */  struct rte_hash;
>>    
>> +/**
>> + * @warning
>> + * @b EXPERIMENTAL: this API may change without prior notice.
>> + *
>> + * @internal A hash table iterator state structure.
>> + */
>> +struct rte_hash_iterator_state {
>> +    uint8_t space[64];
>> I would call this 'state'. 64 can be replaced by 'RTE_CACHE_LINE_SIZE'.
> 
>      Okay.

    I think we should not replace 64 with RTE_CACHE_LINE_SIZE because the ABI 
would change based on the architecture for which it's compiled.

Ok. May be have a #define for 64?

[ ]'s
Michel Machado

Reply via email to