On 13-Jul-18 5:20 PM, Reshma Pattan wrote:
Autotest is enhanced with additional test cases
being added to autotest_data.py

You're also removing PCI autotest - commit message needs to call this out as well.


Cc: sta...@dpdk.org

Signed-off-by: Reshma Pattan <reshma.pat...@intel.com>
Signed-off-by: Jananee Parthasarathy <jananeex.m.parthasara...@intel.com>
---
  test/test/autotest_data.py | 370 ++++++++++++++++++++++++++++++++++++++++++++-
  1 file changed, 362 insertions(+), 8 deletions(-)

diff --git a/test/test/autotest_data.py b/test/test/autotest_data.py

<snip>

+    {
+        "Name":    "Dump_ring",
+        "Command": "dump_ring",
+        "Func":    default_autotest,
+        "Report":  None,
+    },
+    {
+        "Name":    "Quit",
+        "Command": "quit",
+        "Func":    default_autotest,
+        "Report":  None,
+    },

Why is "quit" an autotest? If you want to test "quit" functionality, i would suggest putting it at the end of non-parallel tests, to avoid situation where test prematurely stops (for example, this will happen on FreeBSD, where there's only one thread executing these tests).

But really, having it in this list is IMO dubious.

+    {
+        "Name":    "Set rxtx mode",
+        "Command": "set_rxtx_mode",
+        "Func":    default_autotest,
+        "Report":  None,
+    },
+    {
+        "Name":    "Set rxtx anchor",
+        "Command": "set_rxtx_anchor",
+        "Func":    default_autotest,
+        "Report":  None,
+    },
+    {
+        "Name":    "Set rxtx sc",
+        "Command": "set_rxtx_sc",
+        "Func":    default_autotest,
+        "Report":  None,
+    },
+    {
+        "Name":    "Event eth rx adapter autotest",
+        "Command": "event_eth_rx_adapter_autotest",
+        "Func":    default_autotest,
+        "Report":  None,
+    },
+    {
+        "Name":    "Rawdev autotest",
+        "Command": "rawdev_autotest",
+        "Func":    default_autotest,
+        "Report":  None,
+    },
+    {
+        "Name":    "Kvargs autotest",
+        "Command": "kvargs_autotest",
+        "Func":    default_autotest,
+        "Report":  None,
+    },
+    {
+        "Name":    "Dump physmem",
+        "Command": "dump_physmem",
+        "Func":    default_autotest,
+        "Report":  None,
+    },
+    {
+        "Name":    "Dump memzone",
+        "Command": "dump_memzone",
+        "Func":    default_autotest,
+        "Report":  None,
+    },

Here and in other "dump" autotests - do these dump tests work as autotests? Default autotest function expects a "Test OK" at the end of test, and i don't think dump autotests return that, so this will (should?) cause a very long timeout and a test failure. These should have "dump_autotest" as "Func" value - that function correctly parses output of dump autotests (or, to be more accurate, it doesn't - as long as test doesn't crash, it's considered to be successful :) ).

Also, for readability, we should move these dump tests together and have all dump tests one after the other.

--
Thanks,
Anatoly

Reply via email to