Hi Pablo >-----Original Message----- >From: Verma, Shally >Sent: 18 June 2018 11:00 >To: 'De Lara Guarch, Pablo' <pablo.de.lara.gua...@intel.com> >Cc: Trahe, Fiona <fiona.tr...@intel.com>; akhil.go...@nxp.com; dev@dpdk.org; >Athreya, Narayana Prasad ><narayanaprasad.athr...@cavium.com>; Sahu, Sunila <sunila.s...@cavium.com>; >Gupta, Ashish <ashish.gu...@cavium.com> >Subject: RE: [PATCH v3 5/6] crypto/openssl: add asym crypto support > //snip
>>> >> >>> >> .session_get_size = openssl_pmd_session_get_size, >>> >> + .asym_session_get_size = >>> >> openssl_pmd_asym_session_get_size, >>> >> .session_configure = openssl_pmd_session_configure, >>> >> - .session_clear = openssl_pmd_session_clear >>> >> + .asym_session_configure = >>> >> openssl_pmd_asym_session_configure, >>> >> + .session_clear = openssl_pmd_session_clear, >>> >> + .asym_session_clear = openssl_pmd_asym_session_clear >>> >> }; >>> > >>> >I think session_get_size, session_configure and session_clear should be >>> >renamed to sym_session_*, to avoid confusion. Could you add another patch >>> renaming these? >>> > >>> [Shally] I see in latest cryptodev these typedefs are already named to >>> cryptodev_sym_configure_session_t, _sym_get_session_private_size_t and >>> _sym_free_.. so these changes would come while rebase. >>> or you are referring to change openssl_pmd_session_configure to >>> openssl_pmd_sym_session_configure and so others? >> >>Yes, but the name is still session_configure/clear, not >>sym_session_configure/clear, right? >>And also, I think we should rename the OpenSSL functions, >>openssl_pmd_session_*, >>to openssl_pmd_sym_session_*. >> >[Shally] Ok. I will look into this. > [Shally] if I change these names in struct rte_cryptodev_ops, then we will need to change all drivers. I think that should be done in a separate patch series specific to rename these. For now, I will rename only openssl pmd APIs to use _sym version for this patch series. >Thanks >Shally > >>Pablo >> >>> >>> Thanks for review. >>> >>> >Thanks, >>> >Pablo >>> >