The dev_id parameter to fill_event_buffer() should be 16 bit, also rename to to eth_dev_id to avoid confusion with event device id elsewhere in the file.
Fixes: c2189c907dd1 ("eventdev: make ethdev port identifiers 16-bit") Cc: sta...@dpdk.org Signed-off-by: Nikhil Rao <nikhil....@intel.com> --- lib/librte_eventdev/rte_event_eth_rx_adapter.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/lib/librte_eventdev/rte_event_eth_rx_adapter.c b/lib/librte_eventdev/rte_event_eth_rx_adapter.c index 6f70509..273df1e 100644 --- a/lib/librte_eventdev/rte_event_eth_rx_adapter.c +++ b/lib/librte_eventdev/rte_event_eth_rx_adapter.c @@ -418,14 +418,14 @@ static uint16_t gcd_u16(uint16_t a, uint16_t b) static inline void fill_event_buffer(struct rte_event_eth_rx_adapter *rx_adapter, - uint8_t dev_id, + uint16_t eth_dev_id, uint16_t rx_queue_id, struct rte_mbuf **mbufs, uint16_t num) { uint32_t i; struct eth_device_info *eth_device_info = - &rx_adapter->eth_devices[dev_id]; + &rx_adapter->eth_devices[eth_dev_id]; struct eth_rx_queue_info *eth_rx_queue_info = ð_device_info->rx_queue[rx_queue_id]; -- 1.8.3.1