Thomas, v5: commit message arranged, all warnings from checkpatch.pl fixed except:
WARNING: Macros with flow control statements should be avoided #104: FILE: lib/librte_kni/rte_kni.c:62: +#define KNI_MEM_CHECK(cond) do { if (cond) goto kni_fail; } while (0) a) This MACRO was there before, I just re-factored it to make it more readable. b) There are 4 lines exceeding 80cols due to long quoted strings. I followed kernel convention not to split them in multiple lines. Thanks and regards Marc On 21/10/14 10:29, Thomas Monjalon wrote: > Hi Marc, > > 2014-10-18 00:51, Marc Sune: >> This patch implements the KNI memzone pool in order to prevent >> memzone exhaustion when allocating/deallocating KNI interfaces. >> >> It adds a new API call, rte_kni_init(max_kni_ifaces) that shall >> be called before any call to rte_kni_alloc() if KNI is used. >> >> v2: Moved KNI fd opening to rte_kni_init(). Revised style. >> v3: Adapted kni examples/tests to rte_kni_init(). >> v4: Improved example integration. Fixed kni_memzone_pool_alloc/release() bug. >> >> Signed-off-by: Marc Sune <marc.sune at bisdn.de> > Thanks for the good work with Helin. > Before applying this patch, I'd like another version explaining in the > commit log why this change is needed. > And please use to checkpatch.pl to check and remove whitespace errors. > > Thanks