This patchset fixes a few issues found during validation, and also does a bunch of renames (so that internally-used data structures aren't starting with rte_) and fixes a few typos.
Anatoly Burakov (10): ip_frag: rename RTE_IP_FRAG_ASSERT to IP_FRAG_ASSERT ip_frag: fix debug macros ip_frag: renaming rte_ip_frag_pkt to ip_frag_pkt ip_frag: fix stats macro, rename rte_ip_frag_tbl_stat structure ip_frag: small fix, replace hardcode with a macro ip_frag: replace memmove with custom copying ip_frag: fix order of arguments to key compare function ip_fragmentation: small fixes ip_reassembly: small fixes rte_ip_frag: API header file fix config/common_bsdapp | 1 + config/common_linuxapp | 1 + examples/ip_fragmentation/main.c | 6 +++++- examples/ip_reassembly/main.c | 16 ++++++++++------ lib/librte_ip_frag/ip_frag_common.h | 22 +++++++++++----------- lib/librte_ip_frag/ip_frag_internal.c | 28 ++++++++++++++-------------- lib/librte_ip_frag/rte_ip_frag.h | 20 ++++++++++---------- lib/librte_ip_frag/rte_ipv4_fragmentation.c | 2 +- lib/librte_ip_frag/rte_ipv4_reassembly.c | 10 +++++----- lib/librte_ip_frag/rte_ipv6_fragmentation.c | 2 +- lib/librte_ip_frag/rte_ipv6_reassembly.c | 16 +++++++++++++--- 11 files changed, 72 insertions(+), 52 deletions(-) -- 1.8.1.4