On Tue, Dec 16, 2014 at 01:50:06PM +0000, Bruce Richardson wrote: > On Tue, Dec 16, 2014 at 02:40:09PM +0100, Thomas Monjalon wrote: > > 2014-12-16 13:27, Bruce Richardson: > > > The port mask parsing in testpmd allowed up to 64 bits to be processed, > > > even if RTE_MAX_ETHPORTS is set to a max of 32. Fix this by only > > > processing up to min(RTE_MAX_ETHPORTS,64) bits of the mask. > > [...] > > > - for (i = 0; i < 64; i++) { > > > + for (i = 0; i < 64 && i < RTE_MAX_ETHPORTS; i++) { > > > > Why not use RTE_MIN? > > > > -- > > Thomas > > Because this works equally well, and the change is simpler and clearer IMHO. > However, if you feel very strongly about it, I can change it to use RTE_MIN > instead. :-) > > /Bruce >
Please do, checking the same variable for being less than 2 different values isn't common practice. Its common, and far more readable to use a min function as Thomas indicates. It also saves you doing an extra comparison every loop iteration. Neil