This patch is a draft of TSO on 82599. That is, it is not expected to be accepted as is. The problem is where to put the mss field. In this patch, the mss is put in the union of hash in rte_pktmbuf. It is not the best place, but it is quite convenient, since hash is not used in TX procedure. The idea is to avoid increasing sizeof(struct rte_pktmbuf), while keeping mss easy to access.
However, the hash is also misleading, coz mss has nothing to do with Rx hash. A more formal way could be rename hash as below: union { uint32_t data; struct rx_hash hash; uint32_t tx_mss; } misc; It is gonna be a major change coz it affects the core data structure. Any comments will be appreciated. Qinglai Xiao (1): ixgbe: TCP/UDP segment offload support on 82599. lib/librte_mbuf/rte_mbuf.h | 6 +++++- lib/librte_pmd_ixgbe/ixgbe_rxtx.c | 32 +++++++++++++++++++++++++++++--- 2 files changed, 34 insertions(+), 4 deletions(-) -- 1.7.10.4