On 2013-12-20, Gary Gregory wrote:

> On Fri, Dec 20, 2013 at 12:21 PM, Emmanuel Bourg <ebo...@apache.org> wrote:

>> Le 20/12/2013 18:18, ggreg...@apache.org a écrit :

>>> Remove some unnecessary parentheses.

>> I'd argue they make the code easier to read. Reading bit shifting code
>> is quite painful, some parentheses help greatly.


> That's why it's only "some" and not "all" unnecessary parentheses.

> IMO:

>    tableSize = (1 << 8);

agree in this case, but not with

-            value |= (nextByte << (8 * i));
+            value |= nextByte << 8 * i;

<http://svn.apache.org/viewvc/commons/proper/compress/trunk/src/main/java/org/apache/commons/compress/archivers/sevenz/SevenZFile.java?r1=1552740&r2=1552739&pathrev=1552740>

at least I need to think about it to be really sure * has precedence
over <<

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@commons.apache.org
For additional commands, e-mail: dev-h...@commons.apache.org

Reply via email to