On 6 August 2013 15:48, Gary Gregory <garydgreg...@gmail.com> wrote: > The class names in [csv] are (pp) means package private, others are public > > org.apache.commons.csv.Constants (pp) > org.apache.commons.csv.CSVFormat > org.apache.commons.csv.CSVLexer
That is also (pp) > org.apache.commons.csv.CSVParser > org.apache.commons.csv.CSVPrinter > org.apache.commons.csv.CSVRecord > org.apache.commons.csv.ExtendedBufferedReader (pp) > org.apache.commons.csv.Lexer (pp) > org.apache.commons.csv.Quote > org.apache.commons.csv.Token (pp) > > So all of the _public_ types except Quote are prefixed with "CSV". > > - Should all types be prefixed with "CSV"? > - Should Quote be renamed to CSVQuote? > > - I personally, prefer the prefix "Csv", but I might be in the minority > here. Could also rename Lexer as AbstractLexer and then drop all the CSV/Csv prefixes. And/or possibly merge Lexer and CSVLexer. I think they were separated to make testing alternate implementations easier. But it's probably better to just copy all the relevant classes if we need to revisit the benchmarks. > Gary > > -- > E-Mail: garydgreg...@gmail.com | ggreg...@apache.org > Java Persistence with Hibernate, Second > Edition<http://www.manning.com/bauer3/> > JUnit in Action, Second Edition <http://www.manning.com/tahchiev/> > Spring Batch in Action <http://www.manning.com/templier/> > Blog: http://garygregory.wordpress.com > Home: http://garygregory.com/ > Tweet! http://twitter.com/GaryGregory --------------------------------------------------------------------- To unsubscribe, e-mail: dev-unsubscr...@commons.apache.org For additional commands, e-mail: dev-h...@commons.apache.org