sebb wrote:

> The issue
> https://issues.apache.org/jira/browse/IO-330
> 
> added 4 methods:
> public static BufferedXXXX asBufferedXXXX(final XXXX xxxx)
> where XXXX = InputStream, OutputStream, Reader, Writer
> 
> I just noticed that
> https://issues.apache.org/jira/browse/IO-233
> suggests overloaded methods called buffer instead:
> 
> public static BufferedXXXX buffer(final XXXX xxxx)
> 
> This is quite a lot easier to type, so I propose to rename the methods
> (and link the JIRAs) unless there are objections.

+1

However, I'd wrap the provided stream/reader/writer only, if it is not 
already a (derived) buffered implementation.

Cheers,
Jörg



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@commons.apache.org
For additional commands, e-mail: dev-h...@commons.apache.org

Reply via email to