2012/7/9 Gilles Sadowski <gil...@harfang.homelinux.org>: > On Sat, Jul 07, 2012 at 01:49:25PM +0200, Sébastien Brisard wrote: >> Hello, >> most existing methods in class RealVector allow method chaining. > > Chaining does not always make for readable code. > >> However, some methods just return void instead of this >> - addToEntry >> - set >> - setEntry >> - setSubVector >> - unitize >> >> Are you OK with having all or only some (which ones) methods return this? > > +0 (for people who like it). > I agree, I generally find confusing methods which return {@code this}, but I have to admit that in this context, a fluent interface is very useful. Sébastien > > [And for API consistency.] > > > Gilles > > --------------------------------------------------------------------- > To unsubscribe, e-mail: dev-unsubscr...@commons.apache.org > For additional commands, e-mail: dev-h...@commons.apache.org >
--------------------------------------------------------------------- To unsubscribe, e-mail: dev-unsubscr...@commons.apache.org For additional commands, e-mail: dev-h...@commons.apache.org