Maybe setAllEntries? That would be consistent with setEntry?
What about RealVector? The method set(double) should be renamed also?
Sébastien

2011/8/22 Ted Dunning <ted.dunn...@gmail.com>:
> On Mon, Aug 22, 2011 at 1:27 PM, Phil Steitz <phil.ste...@gmail.com> wrote:
>
>> I think it would be good to add this, but it would probably be
>> better to give it a different name.  What name, I am not sure.
>> Maybe setAll or fill.  Might also be useful to have versions that
>> fill submatrics.
>>
>
> Mahout allows this via overloading of an assign method.
>  Matrix.assign(double) over-writes all cells with a constant value.
>  Matrix.assign(Matrix) copies data into the target.  x.assign(Matrix y,
> BinaryFunction f) does element-wise x_ij = f(x_ij, y_ij)
>
>
>> Here is a little joke to lighten things up a bit.  What if we just
>> allow people to specify negative indices to mean "everything."  So
>> for example, setEntry(-1, -1, 0) sets all entries to 0, setEntry(1,
>> -1, 0) sets the first row to 0.  Just kidding ;)
>>
>
> Can be useful.
>
> I find the TCL convention more useful where -1 refers to the last element of
> a vector.
>
> This sort of thing does tend to freak out the more mathematically inclined
> and it does make it harder to catch errors in mathematical code since it
> mutes indexing errors.
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@commons.apache.org
For additional commands, e-mail: dev-h...@commons.apache.org

Reply via email to